aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test')
-rw-r--r--recipes-test/bootrr/bootrr_git.bb19
-rw-r--r--recipes-test/diag/diag/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch36
-rw-r--r--recipes-test/diag/diag_git.bb6
-rw-r--r--recipes-test/images/initramfs-test-full-image.bb44
-rw-r--r--recipes-test/images/initramfs-test-image.bb31
-rw-r--r--recipes-test/images/initramfs-tiny-image.bb14
-rw-r--r--recipes-test/lava-test-shell/lava-test-shell.bb2
-rw-r--r--recipes-test/mybw/mybw/0001-makefile-Allow-CFLAGS-LDFLAGS-from-environment.patch31
-rw-r--r--recipes-test/mybw/mybw_git.bb24
9 files changed, 127 insertions, 80 deletions
diff --git a/recipes-test/bootrr/bootrr_git.bb b/recipes-test/bootrr/bootrr_git.bb
new file mode 100644
index 0000000..01637b4
--- /dev/null
+++ b/recipes-test/bootrr/bootrr_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "simple low-level testing tool for qcom boards"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=987293312a134ab40eec5f3d446cfaff"
+
+SRCREV = "bd84c8a164e9c603db85781cfa019b516a6d2ded"
+SRC_URI = "\
+ git://github.com/andersson/bootrr.git;branch=master;protocol=https \
+"
+
+S = "${WORKDIR}/git"
+
+PV = "0.0+git${SRCPV}"
+
+inherit allarch
+
+do_install() {
+ oe_runmake install 'DESTDIR=${D}'
+}
diff --git a/recipes-test/diag/diag/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch b/recipes-test/diag/diag/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
deleted file mode 100644
index 67e5f13..0000000
--- a/recipes-test/diag/diag/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 5ee7d4623d10374107de171c796f76054c676c75 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 16 Nov 2020 10:36:43 -0800
-Subject: [PATCH] Disable use of __NR_io_getevents when not defined
-
-Architectures like riscv32 do not define this syscall, therefore return
-ENOSYS on such architectures
-
-Upstream-Status: Submitted [https://github.com/andersson/diag/pull/5]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- router/watch.c | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
---- a/router/watch.c
-+++ b/router/watch.c
-@@ -102,10 +102,17 @@ static long io_destroy(aio_context_t ctx
- return syscall(__NR_io_destroy, ctx);
- }
-
--static long io_getevents(aio_context_t ctx, long min_nr, long nr,
-- struct io_event *events, struct timespec *tmo)
-+static long io_getevents(__attribute__((unused)) aio_context_t ctx,
-+ __attribute__((unused)) long min_nr,
-+ __attribute__((unused)) long nr,
-+ __attribute__((unused)) struct io_event *events,
-+ __attribute__((unused)) struct timespec *tmo)
- {
-+#ifdef __NR_io_getevents
- return syscall(__NR_io_getevents, ctx, min_nr, nr, events, tmo);
-+#else
-+ return -ENOSYS;
-+#endif
- }
-
- static long io_setup(unsigned nr_reqs, aio_context_t *ctx)
diff --git a/recipes-test/diag/diag_git.bb b/recipes-test/diag/diag_git.bb
index a42c126..ef444bd 100644
--- a/recipes-test/diag/diag_git.bb
+++ b/recipes-test/diag/diag_git.bb
@@ -3,12 +3,10 @@ HOMEPAGE = "https://github.com/andersson/diag"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f6832ae4af693c6f31ffd931e25ef580"
-SRC_URI = "git://github.com/andersson/diag.git;protocol=https \
- file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
- "
+SRC_URI = "git://github.com/andersson/diag.git;branch=master;protocol=https"
PV = "0.0+git${SRCPV}"
-SRCREV = "cc5dc0dec3f584d4a500fa36b983e6e77a98e478"
+SRCREV = "d06e599d197790c9e84ac41a51bf124a69768c4f"
S = "${WORKDIR}/git"
diff --git a/recipes-test/images/initramfs-test-full-image.bb b/recipes-test/images/initramfs-test-full-image.bb
index 4081688..d3a5e97 100644
--- a/recipes-test/images/initramfs-test-full-image.bb
+++ b/recipes-test/images/initramfs-test-full-image.bb
@@ -1,70 +1,46 @@
-require recipes-test/images/initramfs-tiny-image.bb
+require recipes-test/images/initramfs-test-image.bb
DESCRIPTION = "Relatively larger ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL += " \
- bluez5 \
+ bootrr \
coreutils \
- dhcpcd \
- diag \
- e2fsprogs \
- e2fsprogs-e2fsck \
- e2fsprogs-mke2fs \
- e2fsprogs-resize2fs \
- e2fsprogs-tune2fs \
- ethtool \
- gptfdisk \
- iw \
hdparm \
kexec \
- lava-test-shell \
- libdrm-tests \
lsof \
ncurses \
ncurses-terminfo \
ncurses-terminfo-base \
- pciutils \
- pd-mapper \
- qrtr \
- rmtfs \
stress-ng \
- tqftpserv \
- usbutils \
util-linux \
util-linux-chrt \
util-linux-lsblk \
- wpa-supplicant \
"
-PACKAGE_INSTALL:append:libc-glibc += " \
+PACKAGE_INSTALL:append:libc-glibc = " \
rt-tests \
"
# We'd like to include extra packages provided by layers which we do not depend
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
-PACKAGE_INSTALL_openembedded_layer += " \
+
+# ncurses-terminfo is provided by oe-core layer, but it's only needed for gps (cgps), so include it here
+PACKAGE_INSTALL_openembedded-layer += " \
crash \
- cryptsetup \
- devmem2 \
dhrystone \
+ gpsd \
+ gpsd-machine-conf \
+ gps-utils \
iozone3 \
libgpiod \
libgpiod-tools \
lmbench \
makedumpfile \
mbw \
+ ncurses-terminfo-base \
sysbench \
tinymembench \
tiobench \
whetstone \
"
-
-PACKAGE_INSTALL_networking_layer += " \
- iperf2 \
- iperf3 \
- tcpdump \
-"
-
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "openembedded-layer", "${PACKAGE_INSTALL_openembedded_layer}", "", d)}"
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "networking-layer", "${PACKAGE_INSTALL_networking_layer}", "", d)}"
diff --git a/recipes-test/images/initramfs-test-image.bb b/recipes-test/images/initramfs-test-image.bb
index 746c8df..3c19996 100644
--- a/recipes-test/images/initramfs-test-image.bb
+++ b/recipes-test/images/initramfs-test-image.bb
@@ -3,41 +3,62 @@ require recipes-test/images/initramfs-tiny-image.bb
DESCRIPTION = "Small ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL += " \
+ alsa-utils-alsaucm \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ alsa-utils-speakertest \
bluez5 \
+ bootrr \
+ debugcc \
dhcpcd \
diag \
+ dropbear \
e2fsprogs \
e2fsprogs-e2fsck \
e2fsprogs-mke2fs \
e2fsprogs-resize2fs \
e2fsprogs-tune2fs \
ethtool \
+ fastrpc \
gptfdisk \
+ i2c-tools \
iw \
lava-test-shell \
libdrm-tests \
+ lrzsz \
+ mybw \
pciutils \
pd-mapper \
qrtr \
rmtfs \
+ strace \
tqftpserv \
usbutils \
+ util-linux-lscpu \
+ util-linux-taskset \
wpa-supplicant \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'kmscube', '', d)} \
"
# We'd like to include extra packages provided by layers which we do not depend
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
-PACKAGE_INSTALL_openembedded_layer += " \
+PACKAGE_INSTALL_openembedded-layer += " \
+ android-tools-adbd \
+ android-tools-adbd-cmdline \
+ cpufrequtils \
cryptsetup \
devmem2 \
+ lmsensors-config-libsensors \
+ lmsensors-sensors \
+ media-ctl \
+ read-edid \
+ yavta \
"
-PACKAGE_INSTALL_networking_layer += " \
+PACKAGE_INSTALL_networking-layer += " \
iperf2 \
iperf3 \
+ phytool \
tcpdump \
"
-
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "openembedded-layer", "${PACKAGE_INSTALL_openembedded_layer}", "", d)}"
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "networking-layer", "${PACKAGE_INSTALL_networking_layer}", "", d)}"
diff --git a/recipes-test/images/initramfs-tiny-image.bb b/recipes-test/images/initramfs-tiny-image.bb
index c70ccee..e9f185b 100644
--- a/recipes-test/images/initramfs-tiny-image.bb
+++ b/recipes-test/images/initramfs-tiny-image.bb
@@ -15,6 +15,7 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+IMAGE_NAME_SUFFIX ?= ""
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"
@@ -33,3 +34,16 @@ local_autologin () {
sed -i -e 's/^\(ExecStart *=.*getty \)/\1--autologin root /' ${LOCAL_GETTY}
}
ROOTFS_POSTPROCESS_COMMAND += "${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', 'local_autologin;', '', d)}"
+
+# We'd like to include extra packages provided by layers which we do not depend
+# on. This can be handled by .bbappends, but then image recipes including this
+# one would not get all these tools. So simulate dynamic bbappend here.
+#
+# To use it define PACKAGE_INSTALL_foo-layer variable containing the list of
+# packages to be installed if (and only if) layer foo-layer is enabled.
+python() {
+ for layer in d.getVar("BBFILE_COLLECTIONS", True).split():
+ extra = d.getVar("PACKAGE_INSTALL_%s" % layer)
+ if extra:
+ d.appendVar("PACKAGE_INSTALL", " " + extra)
+}
diff --git a/recipes-test/lava-test-shell/lava-test-shell.bb b/recipes-test/lava-test-shell/lava-test-shell.bb
index 4218c35..92daeb2 100644
--- a/recipes-test/lava-test-shell/lava-test-shell.bb
+++ b/recipes-test/lava-test-shell/lava-test-shell.bb
@@ -1,7 +1,7 @@
SUMMARY = "Lava test shell helpers"
SECTION = "test"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRCREV = "dcf554ef9b89c74d028734c74edea1ef5e777d33"
diff --git a/recipes-test/mybw/mybw/0001-makefile-Allow-CFLAGS-LDFLAGS-from-environment.patch b/recipes-test/mybw/mybw/0001-makefile-Allow-CFLAGS-LDFLAGS-from-environment.patch
new file mode 100644
index 0000000..77fbc94
--- /dev/null
+++ b/recipes-test/mybw/mybw/0001-makefile-Allow-CFLAGS-LDFLAGS-from-environment.patch
@@ -0,0 +1,31 @@
+From bde677567226a8b7a6c773f863d3f820eca26000 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 22 Oct 2022 16:13:47 -0700
+Subject: [PATCH] makefile: Allow CFLAGS/LDFLAGS from environment.
+
+This helps in cross-compilation where the flags passed from environment
+will matter much e.g. ABI, architecture etc.
+
+Upstream-Status: Submitted [https://github.com/andersson/mybw/pull/1]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index dfbba09..28a96bc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ OUT := mybw
+
+-CFLAGS := -O2 -Wall -fno-builtin
+-LDFLAGS := -static -static-libgcc
++CFLAGS += -O2 -Wall -fno-builtin
++LDFLAGS += -static -static-libgcc
+
+ SRCS := mybw.c
+ OBJS := $(SRCS:.c=.o)
+--
+2.38.1
+
diff --git a/recipes-test/mybw/mybw_git.bb b/recipes-test/mybw/mybw_git.bb
new file mode 100644
index 0000000..17e2336
--- /dev/null
+++ b/recipes-test/mybw/mybw_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Quick hack to measure memory read performance."
+HOMEPAGE = "https://github.com/andersson/mybw"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause-Clear;md5=7a434440b651f4a472ca93716d01033a"
+
+SRCREV = "f4bdeee1266c273e308d0651522bb59afb5b8211"
+SRC_URI = "git://github.com/andersson/mybw;protocol=https;branch=main \
+ file://0001-makefile-Allow-CFLAGS-LDFLAGS-from-environment.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+PV = "0.0+git${SRCPV}"
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 mybw ${D}${bindir}/mybw
+}
+
+LDFLAGS += "-lgcc"