aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test/images/initramfs-test-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/images/initramfs-test-image.bb')
-rw-r--r--recipes-test/images/initramfs-test-image.bb31
1 files changed, 26 insertions, 5 deletions
diff --git a/recipes-test/images/initramfs-test-image.bb b/recipes-test/images/initramfs-test-image.bb
index 746c8df..3c19996 100644
--- a/recipes-test/images/initramfs-test-image.bb
+++ b/recipes-test/images/initramfs-test-image.bb
@@ -3,41 +3,62 @@ require recipes-test/images/initramfs-tiny-image.bb
DESCRIPTION = "Small ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL += " \
+ alsa-utils-alsaucm \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ alsa-utils-speakertest \
bluez5 \
+ bootrr \
+ debugcc \
dhcpcd \
diag \
+ dropbear \
e2fsprogs \
e2fsprogs-e2fsck \
e2fsprogs-mke2fs \
e2fsprogs-resize2fs \
e2fsprogs-tune2fs \
ethtool \
+ fastrpc \
gptfdisk \
+ i2c-tools \
iw \
lava-test-shell \
libdrm-tests \
+ lrzsz \
+ mybw \
pciutils \
pd-mapper \
qrtr \
rmtfs \
+ strace \
tqftpserv \
usbutils \
+ util-linux-lscpu \
+ util-linux-taskset \
wpa-supplicant \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'kmscube', '', d)} \
"
# We'd like to include extra packages provided by layers which we do not depend
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
-PACKAGE_INSTALL_openembedded_layer += " \
+PACKAGE_INSTALL_openembedded-layer += " \
+ android-tools-adbd \
+ android-tools-adbd-cmdline \
+ cpufrequtils \
cryptsetup \
devmem2 \
+ lmsensors-config-libsensors \
+ lmsensors-sensors \
+ media-ctl \
+ read-edid \
+ yavta \
"
-PACKAGE_INSTALL_networking_layer += " \
+PACKAGE_INSTALL_networking-layer += " \
iperf2 \
iperf3 \
+ phytool \
tcpdump \
"
-
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "openembedded-layer", "${PACKAGE_INSTALL_openembedded_layer}", "", d)}"
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "networking-layer", "${PACKAGE_INSTALL_networking_layer}", "", d)}"