aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test/images/initramfs-test-full-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/images/initramfs-test-full-image.bb')
-rw-r--r--recipes-test/images/initramfs-test-full-image.bb44
1 files changed, 10 insertions, 34 deletions
diff --git a/recipes-test/images/initramfs-test-full-image.bb b/recipes-test/images/initramfs-test-full-image.bb
index 4081688..d3a5e97 100644
--- a/recipes-test/images/initramfs-test-full-image.bb
+++ b/recipes-test/images/initramfs-test-full-image.bb
@@ -1,70 +1,46 @@
-require recipes-test/images/initramfs-tiny-image.bb
+require recipes-test/images/initramfs-test-image.bb
DESCRIPTION = "Relatively larger ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL += " \
- bluez5 \
+ bootrr \
coreutils \
- dhcpcd \
- diag \
- e2fsprogs \
- e2fsprogs-e2fsck \
- e2fsprogs-mke2fs \
- e2fsprogs-resize2fs \
- e2fsprogs-tune2fs \
- ethtool \
- gptfdisk \
- iw \
hdparm \
kexec \
- lava-test-shell \
- libdrm-tests \
lsof \
ncurses \
ncurses-terminfo \
ncurses-terminfo-base \
- pciutils \
- pd-mapper \
- qrtr \
- rmtfs \
stress-ng \
- tqftpserv \
- usbutils \
util-linux \
util-linux-chrt \
util-linux-lsblk \
- wpa-supplicant \
"
-PACKAGE_INSTALL:append:libc-glibc += " \
+PACKAGE_INSTALL:append:libc-glibc = " \
rt-tests \
"
# We'd like to include extra packages provided by layers which we do not depend
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
-PACKAGE_INSTALL_openembedded_layer += " \
+
+# ncurses-terminfo is provided by oe-core layer, but it's only needed for gps (cgps), so include it here
+PACKAGE_INSTALL_openembedded-layer += " \
crash \
- cryptsetup \
- devmem2 \
dhrystone \
+ gpsd \
+ gpsd-machine-conf \
+ gps-utils \
iozone3 \
libgpiod \
libgpiod-tools \
lmbench \
makedumpfile \
mbw \
+ ncurses-terminfo-base \
sysbench \
tinymembench \
tiobench \
whetstone \
"
-
-PACKAGE_INSTALL_networking_layer += " \
- iperf2 \
- iperf3 \
- tcpdump \
-"
-
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "openembedded-layer", "${PACKAGE_INSTALL_openembedded_layer}", "", d)}"
-PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "networking-layer", "${PACKAGE_INSTALL_networking_layer}", "", d)}"