aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/DLT-daemon/DLT-daemon_2.5.2.bb28
-rw-r--r--recipes-extended/shadow-securetty/shadow-securetty/securetty-vea97
-rw-r--r--recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend19
3 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/DLT-daemon/DLT-daemon_2.5.2.bb b/recipes-extended/DLT-daemon/DLT-daemon_2.5.2.bb
new file mode 100644
index 0000000..f812862
--- /dev/null
+++ b/recipes-extended/DLT-daemon/DLT-daemon_2.5.2.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Diagnostic Log and Trace"
+DESCRIPTION = "This component provides a standardised log and trace interface, based on \
+ thestandardised protocol specified in the AUTOSAR standard 4.0 DLT.This \
+ component can be used by GENIVI components and other applications aslogging \
+ facility providing \
+ - the DLT shared library \
+ - the DLT daemon, including startup scripts \
+ - the DLT daemon adaptors- the DLT client console utilities \
+ - the DLT test applications \
+ "
+HOMEPAGE = "https://www.genivi.org/"
+SECTION = ""console/utils"
+
+inherit gzipnative
+
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99ba60c3fad7eaf8c56bca6dd75cba09 \
+ file://MPL.txt;md5=ccdb2761cef70c8b2612624c323f89dc"
+
+SRC_URI = "git://git.genivi.org/srv/git/DLT-daemon;protocol=git;tag=e08037988036d3a66dbd592576e59c8f834c61c4"
+
+DEPENDS = ""
+
+S = "${WORKDIR}/git"
+
+inherit autotools gettext cmake
+
+FILES_${PN}-doc += "/usr/share/*"
diff --git a/recipes-extended/shadow-securetty/shadow-securetty/securetty-vea9 b/recipes-extended/shadow-securetty/shadow-securetty/securetty-vea9
new file mode 100644
index 0000000..22c00a9
--- /dev/null
+++ b/recipes-extended/shadow-securetty/shadow-securetty/securetty-vea9
@@ -0,0 +1,7 @@
+
+# vexpress A9 ports
+ttyAMA0
+ttyAMA1
+ttyAMA2
+ttyAMA3
+
diff --git a/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend b/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend
new file mode 100644
index 0000000..2af9c5f
--- /dev/null
+++ b/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+SRC_URI_append_vexpressa9 = " file://securetty-vea9"
+
+python do_add_ports () {
+ if ((d.getVar("MACHINE", True) or "").find("vexpressa9") != -1):
+ conf=d.getVar("WORKDIR", True)
+ conf += "/securetty"
+ aconf=d.getVar("WORKDIR", True)
+ aconf += "/securetty-vea9"
+ fin = open(aconf, "r")
+ data = fin.read()
+ fin.close()
+ fout = open(conf, "a")
+ fout.write(data)
+ fout.close()
+}
+
+addtask do_add_ports after do_patch before do_configure \ No newline at end of file