aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend')
-rw-r--r--recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend b/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend
new file mode 100644
index 0000000..2af9c5f
--- /dev/null
+++ b/recipes-extended/shadow-securetty/shadow-securetty_4.1.4.3.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+SRC_URI_append_vexpressa9 = " file://securetty-vea9"
+
+python do_add_ports () {
+ if ((d.getVar("MACHINE", True) or "").find("vexpressa9") != -1):
+ conf=d.getVar("WORKDIR", True)
+ conf += "/securetty"
+ aconf=d.getVar("WORKDIR", True)
+ aconf += "/securetty-vea9"
+ fin = open(aconf, "r")
+ data = fin.read()
+ fin.close()
+ fout = open(conf, "a")
+ fout.write(data)
+ fout.close()
+}
+
+addtask do_add_ports after do_patch before do_configure \ No newline at end of file