aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi/images')
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/ivi-image.bb12
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/ivi-image.inc19
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
new file mode 100644
index 0000000..c4de687
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
@@ -0,0 +1,12 @@
+# Base this image on generic IVI image
+include recipes-yocto-ivi/images/ivi-image.inc
+
+PV = "6.0.1"
+
+IMAGE_INSTALL_append = " \
+ packagegroup-abstract-component-p1 \
+ packagegroup-placeholder-component-p1 \
+ packagegroup-specific-component-p2 \
+ packagegroup-abstract-component-p2 \
+ packagegroup-specific-component-p1 \
+"
diff --git a/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc b/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc
new file mode 100644
index 0000000..2ec2be7
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc
@@ -0,0 +1,19 @@
+IMAGE_INSTALL = "packagegroup-core-boot-genivi ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image buildhistory
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+IMAGE_FEATURES += " package-management"
+
+# Create SD image symlink correctly
+IMAGE_POSTPROCESS_COMMAND_imx53qsb += "rename_symlink ; "
+
+BUILDHISTORY_COMMIT = "1"