aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi')
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/ivi-image.bb12
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/ivi-image.inc19
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb23
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb20
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb49
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-placeholder-component-p1.bb18
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb38
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb25
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-xserver-ivi.bb19
9 files changed, 223 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
new file mode 100644
index 0000000..c4de687
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
@@ -0,0 +1,12 @@
+# Base this image on generic IVI image
+include recipes-yocto-ivi/images/ivi-image.inc
+
+PV = "6.0.1"
+
+IMAGE_INSTALL_append = " \
+ packagegroup-abstract-component-p1 \
+ packagegroup-placeholder-component-p1 \
+ packagegroup-specific-component-p2 \
+ packagegroup-abstract-component-p2 \
+ packagegroup-specific-component-p1 \
+"
diff --git a/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc b/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc
new file mode 100644
index 0000000..2ec2be7
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/images/ivi-image.inc
@@ -0,0 +1,19 @@
+IMAGE_INSTALL = "packagegroup-core-boot-genivi ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image buildhistory
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+IMAGE_FEATURES += " package-management"
+
+# Create SD image symlink correctly
+IMAGE_POSTPROCESS_COMMAND_imx53qsb += "rename_symlink ; "
+
+BUILDHISTORY_COMMIT = "1"
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb
new file mode 100644
index 0000000..f092fe2
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GENIVI P1 Abstract components (AC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-abstract-component-p1 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ bluez5-obex \
+ eglibc \
+ ofono \
+ wayland-ivi-extension \
+ weston \
+ "
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb
new file mode 100644
index 0000000..3a7abb0
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GENIVI P2 Abstract components (AC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-abstract-component-p2 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ node-health-monitor \
+ persistence-client-library \
+ "
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb
new file mode 100644
index 0000000..40dcaf4
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-core-boot-genivi.bb
@@ -0,0 +1,49 @@
+#
+# Contains changes by Wind River Systems, 2013-08-08
+# Copyright (c) 2013 Wind River Systems, Inc.
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+# derived from oe-core: meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+
+SUMMARY = "Minimal boot requirements"
+DESCRIPTION = "The minimal set of packages required to boot the system"
+LICENSE = "MIT"
+DEPENDS = "virtual/kernel"
+PR = "r11"
+
+inherit packagegroup
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#
+# Set by the machine configuration with packages essential for device bootup
+#
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+
+# Distro can override the following VIRTUAL-RUNTIME providers:
+VIRTUAL-RUNTIME_dev_manager ?= "udev"
+VIRTUAL-RUNTIME_login_manager ?= "busybox"
+VIRTUAL-RUNTIME_init_manager ?= "systemd"
+VIRTUAL-RUNTIME_initscripts ?= ""
+VIRTUAL-RUNTIME_keymaps ?= "keymaps"
+
+RDEPENDS_${PN} = "\
+ base-files \
+ base-passwd \
+ busybox \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
+ netbase \
+ ${VIRTUAL-RUNTIME_login_manager} \
+ ${VIRTUAL-RUNTIME_init_manager} \
+ ${VIRTUAL-RUNTIME_initscripts} \
+ ${VIRTUAL-RUNTIME_dev_manager} \
+ ${VIRTUAL-RUNTIME_update-alternatives} \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
+ kmod \
+ procps \
+ util-linux-mount \
+ "
+
+RRECOMMENDS_${PN} = "\
+ ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-placeholder-component-p1.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-placeholder-component-p1.bb
new file mode 100644
index 0000000..f4501f0
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-placeholder-component-p1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "GENIVI P1 Placeholder components (PC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-placeholder-component-p1 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb
new file mode 100644
index 0000000..cee6149
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "GENIVI P1 Specific components (SC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-specific-component-p1 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ kernel-modules \
+ audiomanager \
+ common-api-c++ \
+ dlt-daemon \
+ dlt-daemon-systemd \
+ alsa-lib \
+ alsa-utils \
+ connman \
+ curl \
+ dbus \
+ ecryptfs-utils \
+ gstreamer \
+ gst-plugins-good \
+ gst-plugins-base \
+ libusb1 \
+ node-startup-controller \
+ node-state-manager \
+ openssl \
+ udev \
+ wpa-supplicant \
+ "
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb
new file mode 100644
index 0000000..c098b09
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GENIVI P2 Specific components (SC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-specific-component-p2 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ common-api-c++-dbus \
+ fuse \
+ pulseaudio-server \
+ quota \
+ sqlite3 \
+ wireless-tools \
+ "
+
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-xserver-ivi.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-xserver-ivi.bb
new file mode 100644
index 0000000..2ada89e
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-xserver-ivi.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Packagegroup for xserver and GPU drivers"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+
+inherit packagegroup
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+ "
+
+RDEPENDS_${PN} = " \
+ ${XSERVER}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"