aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_6.%.bbappend (renamed from meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend)0
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch37
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb6
-rw-r--r--meta-openstack/recipes-support/spice-html5/spice-html5_git.bb2
-rw-r--r--meta-openstack/recipes-support/tgt/tgt_git.bb2
5 files changed, 23 insertions, 24 deletions
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend b/meta-openstack/recipes-support/iproute2/iproute2_6.%.bbappend
index 025ee4ee..025ee4ee 100644
--- a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
+++ b/meta-openstack/recipes-support/iproute2/iproute2_6.%.bbappend
diff --git a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
index 4683db0a..79aedffd 100644
--- a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
+++ b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
@@ -7,28 +7,31 @@ This allows the recipe to specify specific values instead of them
being 'discovered' which may lead to host contamination or similar
issues.
+Updated for 4.9.0: Jeremy Puhlman
+
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
----
+----
configure.ac | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
+
diff --git a/configure.ac b/configure.ac
-index 25afe44..b5a9e03 100644
+index 37a0f86..9b77c7f 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -100,26 +100,38 @@ fi
+@@ -106,26 +106,38 @@ fi
AC_SUBST(PYTHON)
+if test -z "${PYTHON_VERSION}"; then
PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("VERSION"))'`
+fi
+if test -z "${PYTHON_LDVERSION}"; then
PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("LDVERSION") or "")'`
+fi
@@ -38,7 +41,7 @@ index 25afe44..b5a9e03 100644
+if test -z "${PYTHON_INCLUDEPY}"; then
CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write("-I" + sysconfig.get_config_var("INCLUDEPY"))'`
+else
+CPPFLAGS1="${PYTHON_INCLUDEPY}"
@@ -46,7 +49,7 @@ index 25afe44..b5a9e03 100644
+if test -z "${PYTHON_CFLAGS}"; then
CPPFLAGS2=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(" ".join(filter(lambda x: x.startswith("-D"), \
sysconfig.get_config_var("CFLAGS").split())))'`
+else
@@ -55,13 +58,13 @@ index 25afe44..b5a9e03 100644
if test "${ENABLE_EMBEDDED}" != "yes"; then
CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED"
-@@ -131,22 +143,43 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
+@@ -137,22 +149,42 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
AC_SUBST(CPPFLAGS)
+if test -z "${PYTHON_LIBDIR}"; then
PYTHONLIBDIR=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("LIBDIR"))'`
+else
+PYTHONLIBDIR="${PYTHON_LIBDIR}"
@@ -76,22 +79,21 @@ index 25afe44..b5a9e03 100644
+fi
+if test -z "${PYTHON_FRAMEWORKDIR}"; then
PYTHONFRAMEWORKDIR=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKDIR"))'`
+else
+PYTHONFRAMEWORKDIR="${PYTHON_FRAMEWORKDIR}"
+fi
-+
+if test -z "${PYTHON_FRAMEWORKPREFIX}"; then
PYTHONFRAMEWORKPREFIX=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKPREFIX"))'`
+else
+PYTHONFRAMEWORKPREFIX="${PYTHON_FRAMEWORKPREFIX}"
+fi
+if test -z "${PYTHON_FRAMEWORK}"; then
PYTHONFRAMEWORK=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'`
+else
+PYTHONFRAMEWORK="${PYTHON_FRAMEWORK}"
@@ -99,20 +101,20 @@ index 25afe44..b5a9e03 100644
if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
-@@ -170,12 +203,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
+@@ -180,12 +212,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
LDLIBS1="-lpython${PYTHON_VERSION}"
fi
+ if test -z "${PYTHON_LIBS}"; then
LDLIBS2=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("LIBS"))'`
+ else
+ LDLIBS2="${PYTHON_LIBS}"
+ fi
+ if test -z "${PYTHON_SYSLIBS}"; then
LDLIBS3=`${PYTHON} -c 'from sys import stdout; \
- from distutils import sysconfig; \
+ import sysconfig; \
stdout.write(sysconfig.get_config_var("SYSLIBS"))'`
+ else
+ LDLIBS3="${PYTHON_SYSLIBS}"
@@ -120,6 +122,3 @@ index 25afe44..b5a9e03 100644
else
LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}"
---
-2.7.4
-
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
index 79afba81..b0daf54d 100644
--- a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -9,8 +9,8 @@ HOMEPAGE = "https://github.com/GrahamDumpleton/mod_wsgi"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "217e80b7436035723b80ff02ee349365e8553dfc"
-PV = "4.6.8+git${SRCPV}"
+SRCREV = "df9faf954a1ab6208f45ba6fde90f0b41f605483"
+PV = "4.9.0+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -20,7 +20,7 @@ SRC_URI = "\
file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
"
-inherit autotools-brokensep distutils3-base
+inherit autotools-brokensep setuptools3-base
DEPENDS += "apache2-native apache2 python3"
RDEPENDS:${PN} = "python3"
diff --git a/meta-openstack/recipes-support/spice-html5/spice-html5_git.bb b/meta-openstack/recipes-support/spice-html5/spice-html5_git.bb
index dac933d1..b69b08c0 100644
--- a/meta-openstack/recipes-support/spice-html5/spice-html5_git.bb
+++ b/meta-openstack/recipes-support/spice-html5/spice-html5_git.bb
@@ -11,7 +11,7 @@ DESCRIPTION = "\
where it is running, but from anywhere on the Internet and from a wide \
variety of machine architectures. \
"
-LICENSE = "GPLv3 & LGPLv3"
+LICENSE = "GPL-3.0-only & LGPL-3.0-only"
LIC_FILES_CHKSUM = "\
file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
diff --git a/meta-openstack/recipes-support/tgt/tgt_git.bb b/meta-openstack/recipes-support/tgt/tgt_git.bb
index b297c9fd..9c5c24bf 100644
--- a/meta-openstack/recipes-support/tgt/tgt_git.bb
+++ b/meta-openstack/recipes-support/tgt/tgt_git.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Linux SCSI target framework (tgt)"
HOMEPAGE = "http://stgt.sourceforge.net"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://scripts/tgtd.spec;beginline=7;endline=7;md5=21c19ea7dad04648b9c2f791b6e29b4c"
DEPENDS = "sg3-utils libaio"