aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/erubis_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb2
13 files changed, 15 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
index 1ade2658..993e2926 100644
--- a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mixlib-log \
json \
hashie \
diff --git a/meta-openstack/recipes-devtools/ruby/erubis_git.bb b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
index 08e0f281..540231a9 100644
--- a/meta-openstack/recipes-devtools/ruby/erubis_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
@@ -21,7 +21,7 @@ SRC_URI = " \
inherit ruby
-do_patch_append() {
+do_patch:append() {
bb.build.exec_func('do_fixup_gemspec', d)
}
diff --git a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
index 768bc218..71b0533e 100644
--- a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
+++ b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
@@ -7,13 +7,13 @@ SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;tag=v${PV}"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
+RDEPENDS:${PN} = "cool.io http-parser.rb msgpack serverengine sigdump strptime tzinfo tzinfo-data yajl-ruby"
inherit ruby
-do_install_append() {
+do_install:append() {
install -d ${D}/etc/fluent/
install ${S}/fluent.conf ${D}/etc/fluent/fluent.conf
}
-INSANE_SKIP_${PN} = "installed-vs-shipped"
+INSANE_SKIP:${PN} = "installed-vs-shipped"
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
index db52ebd5..6bf809ed 100644
--- a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
@@ -16,7 +16,7 @@ DEPENDS = "git"
inherit ruby
# Download the submodules
-do_configure_prepend() {
+do_configure:prepend() {
cd ${WORKDIR}/git
git submodule update --init --recursive
}
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
index b380e011..c34b74bc 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -22,7 +22,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mixlib-log \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
index b823a033..21fe4064 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
net-ssh \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
index 7da05668..965eae1e 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
net-ssh \
net-ssh-gateway \
"
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
index 5820c44d..ee5c7351 100644
--- a/meta-openstack/recipes-devtools/ruby/ohai_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -25,7 +25,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mime-types \
ipaddress \
mixlib-cli \
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index a4eb63cd..3480cdc9 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -26,7 +26,7 @@ inherit ruby
RUBY_COMPILE_FLAGS = ""
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
coderay \
method-source \
slop \
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
index 923e9f26..0837a3b3 100644
--- a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -23,7 +23,7 @@ SRC_URI = " \
inherit ruby
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
mime-types \
"
diff --git a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
index 1ed8f9e9..516a72eb 100644
--- a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
@@ -8,6 +8,6 @@ SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;tag=v2
S = '${WORKDIR}/git'
-RDEPENDS_${PN} = "sigdump"
+RDEPENDS:${PN} = "sigdump"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb b/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
index 20a1f5bc..53a2f8a0 100644
--- a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
@@ -8,6 +8,6 @@ SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;tag=v0.2.3"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
index 2ea1f2d3..2f7bc66a 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
@@ -8,6 +8,6 @@ SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;tag=v2.0.1"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "concurrent-ruby"
+RDEPENDS:${PN} = "concurrent-ruby"
inherit ruby