aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-core/packagegroups/packagegroup-gaming.bb13
-rw-r--r--meta-amdfalconx86/conf/local.conf.append.amdfalconx8612
2 files changed, 25 insertions, 0 deletions
diff --git a/common/recipes-core/packagegroups/packagegroup-gaming.bb b/common/recipes-core/packagegroups/packagegroup-gaming.bb
new file mode 100644
index 00000000..6f879601
--- /dev/null
+++ b/common/recipes-core/packagegroups/packagegroup-gaming.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Package group targeting gaming components for AMD platforms"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+inherit packagegroup
+
+LUNARG_SDK_COMPONENTS = "glslang spirv-tools vulkan-loader-layers vulkan-tools vulkan-samples"
+
+RDEPENDS_${PN} += "\
+ ${LUNARG_SDK_COMPONENTS} \
+"
diff --git a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86 b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
index 7f090ddd..56552668 100644
--- a/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
+++ b/meta-amdfalconx86/conf/local.conf.append.amdfalconx86
@@ -42,3 +42,15 @@ COMMERCIAL_LIC_FLAGS_MULTIMEDIA = "commercial_gstreamer1.0-plugins-ugly \
commercial_mpg123"
LICENSE_FLAGS_WHITELIST .= "${@' ${COMMERCIAL_LIC_FLAGS_MULTIMEDIA}' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-multimedia-risky' if bb.utils.to_boolean('${INCLUDE_COMMERCIAL_MULTIMEDIA}') else ''}"
+
+# MEL has support for gaming components including LunarG SDK,
+# CodeXL etc. In order to include these components in your final
+# image or generating an ADE which can be used to develop for/against
+# these please change the below define to "yes" before building the
+# image or generating ADE.
+# The list of components this package provides can be seen in the
+# RDEPENDS list of:
+# meta-amd/common/recipes-core/packagegroups/packagegroup-gaming.bb
+INCLUDE_GAMING_COMPONENTS ??= "no"
+
+CORE_IMAGE_EXTRA_INSTALL .= "${@' packagegroup-gaming' if bb.utils.to_boolean('${INCLUDE_GAMING_COMPONENTS}') else ''}"