summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libseccomp/libseccomp_2.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libseccomp/libseccomp_2.5.2.bb')
-rw-r--r--meta/recipes-support/libseccomp/libseccomp_2.5.2.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.2.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.2.bb
deleted file mode 100644
index 3ec6f135c5..0000000000
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.2.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-SUMMARY = "interface to seccomp filtering mechanism"
-DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
-HOMEPAGE = "https://github.com/seccomp/libseccomp"
-SECTION = "security"
-LICENSE = "LGPL-2.1"
-LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
-
-DEPENDS += "gperf-native"
-
-PV .= "+git${SRCPV}"
-SRCREV = "2457dec1a90101d720e89e8027376742e2f3c327"
-
-SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=main \
- file://0001-configure.ac-Bump-version-to-2.5.99.patch \
- file://0001-arch-Add-riscv32-architecture-support.patch \
- file://0002-man-Add-RISCV64-to-arch-list.patch \
- file://0003-syscalls-update-the-syscall-defs-for-Linux-v5.15.0-r.patch \
- file://0004-syscalls-Add-quotactl_path.patch \
- file://run-ptest \
- "
-
-S = "${WORKDIR}/git"
-
-inherit autotools-brokensep pkgconfig ptest features_check
-
-REQUIRED_DISTRO_FEATURES = "seccomp"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
-
-DISABLE_STATIC = ""
-
-do_compile_ptest() {
- oe_runmake -C tests check-build
-}
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- install -d ${D}${PTEST_PATH}/tools
- for file in $(find tests/* -executable -type f); do
- install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
- done
- for file in $(find tests/*.tests -type f); do
- install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
- done
- for file in $(find tools/* -executable -type f); do
- install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
- done
- # Overwrite libtool wrappers with real executables
- for file in $(find tools/.libs/* -executable -type f); do
- install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
- done
-}
-
-FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
-FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
-
-RDEPENDS:${PN}-ptest = "coreutils bash"