summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcheck/libcheck_0.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcheck/libcheck_0.15.2.bb')
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.15.2.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta/recipes-support/libcheck/libcheck_0.15.2.bb b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
index 62823023c7..5ab67b8728 100644
--- a/meta/recipes-support/libcheck/libcheck_0.15.2.bb
+++ b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
@@ -7,27 +7,30 @@ reportable in the following: Subunit, TAP, XML, and a generic logging format."
HOMEPAGE = "https://libcheck.github.io/check/"
SECTION = "devel"
-LICENSE = "LGPLv2.1+"
+LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
-SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \
+SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/check-${PV}.tar.gz \
+ file://automake-output.patch \
file://not-echo-compiler-info-to-check_stdint.h.patch"
SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a"
-UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/"
+GITHUB_BASE_URI = "https://github.com/libcheck/check/releases/"
S = "${WORKDIR}/check-${PV}"
-inherit autotools pkgconfig texinfo
+inherit autotools pkgconfig texinfo github-releases
CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
-RREPLACES_${PN} = "check (<= 0.9.5)"
+RREPLACES:${PN} = "check (<= 0.9.5)"
+do_install:append:class-native() {
+ create_cmdline_shebang_wrapper ${D}${bindir}/checkmk
+}
BBCLASSEXTEND = "native nativesdk"
PACKAGES =+ "checkmk"
-FILES_checkmk = "${bindir}/checkmk"
-
-RDEPENDS_checkmk = "gawk"
+FILES:checkmk = "${bindir}/checkmk"
+RDEPENDS:checkmk = "gawk"