summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
index aa1ac77e16..2e463cd7b3 100644
--- a/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
@@ -2,7 +2,7 @@ SUMMARY = "Fast lightweight tabbed filemanager"
DESCRIPTION = "A free file manager application and the standard file manager of LXDE."
HOMEPAGE = "http://pcmanfm.sourceforge.net/"
-LICENSE = "GPLv2 & GPLv2+ & LGPLv2.1+"
+LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
file://src/pcmanfm.h;endline=22;md5=417b3855771a3a87f8ad753d994491f0 \
file://src/gseal-gtk-compat.h;endline=21;md5=46922c8691f58d124f9420fe16149ce2"
@@ -27,12 +27,14 @@ inherit autotools pkgconfig features_check mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_OECONF = "--with-gtk=3"
+# GCC 14 finds extra incompatible pointer type warnings which are treated as errors
+CFLAGS += "-Wno-error=incompatible-pointer-types"
do_install:append () {
install -d ${D}/${datadir}
install -d ${D}/${datadir}/pixmaps/
- install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${UNPACKDIR}/*.png ${D}/${datadir}/pixmaps
}
FILES:${PN} += "${libdir}/pcmanfm"