summaryrefslogtreecommitdiffstats
path: root/meta/packages/zip/zip_2.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/zip/zip_2.31.bb')
-rw-r--r--meta/packages/zip/zip_2.31.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/zip/zip_2.31.bb b/meta/packages/zip/zip_2.31.bb
new file mode 100644
index 0000000000..6c588a55e5
--- /dev/null
+++ b/meta/packages/zip/zip_2.31.bb
@@ -0,0 +1,17 @@
+SECTION = "console/utils"
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz"
+LICENSE = "Info-ZIP"
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+ 'BINFLAGS=0755' 'INSTALL_D=install -d'"
+
+do_compile() {
+ oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
+ install
+}
+