summaryrefslogtreecommitdiffstats
path: root/meta/packages/zaurus-updater/zaurus-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/zaurus-updater/zaurus-updater.bb')
-rw-r--r--meta/packages/zaurus-updater/zaurus-updater.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/zaurus-updater/zaurus-updater.bb b/meta/packages/zaurus-updater/zaurus-updater.bb
new file mode 100644
index 0000000000..26cf1e5453
--- /dev/null
+++ b/meta/packages/zaurus-updater/zaurus-updater.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
+DEPENDS = "encdec-updater-native"
+LICENSE = "zaurus-updater"
+PR = "r5"
+
+PACKAGES = ""
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
+
+SRC_URI = "file://updater.sh \
+ file://gnu-tar.gz"
+S = "${WORKDIR}"
+
+do_compile() {
+ encdec-updater -e updater.sh
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh.${MACHINE}
+
+ case ${MACHINE} in
+ spitz )
+ install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
+ ;;
+ *)
+ ;;
+ esac
+}
+
+addtask deploy before do_build after do_compile