summaryrefslogtreecommitdiffstats
path: root/meta/packages/pcmciautils/pcmciautils_010.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pcmciautils/pcmciautils_010.bb')
-rw-r--r--meta/packages/pcmciautils/pcmciautils_010.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils_010.bb b/meta/packages/pcmciautils/pcmciautils_010.bb
new file mode 100644
index 0000000000..8045a0e442
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils_010.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
+DEPENDS = "sysfsutils udev module-init-tools"
+RDEPENDS = "udev module-init-tools"
+HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
+S = "${WORKDIR}/pcmciautils-${PV}"
+
+PR = "r3"
+
+export HOSTCC = "${BUILD_CC}"
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export pcmciaconfdir = "${sysconfdir}/pcmcia"
+export udevrulesdir = "${sysconfdir}/udev/rules.d"
+export UDEV = 1
+LD = "${CC}"
+CFLAGS =+ "-I${S}/src"
+CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
+RCONFLICTS_${PN} += "pcmcia-cs"