summaryrefslogtreecommitdiffstats
path: root/meta/packages/oh/usbinit.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oh/usbinit.bb')
-rw-r--r--meta/packages/oh/usbinit.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/oh/usbinit.bb b/meta/packages/oh/usbinit.bb
new file mode 100644
index 0000000000..bfc8490dc1
--- /dev/null
+++ b/meta/packages/oh/usbinit.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Quick hack to start gadget Ethernet on the 770"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "file://usb-gether"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/etc
+ install -d ${D}/etc/init.d
+ install usb-gether ${D}/etc/init.d
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "usb-gether"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."