summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb')
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..46b0acfe2e
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+DEPENDS = "matchbox xmodmap"
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://mb-applet-home \
+ file://home-panelapp.desktop \
+ file://xrandr.png"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+PR = "r6"
+LICENSE = "MIT"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+ install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
+
+}