summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml/files/no-testapi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxml/files/no-testapi.patch')
-rw-r--r--meta/packages/libxml/files/no-testapi.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/libxml/files/no-testapi.patch b/meta/packages/libxml/files/no-testapi.patch
new file mode 100644
index 0000000000..15a4dea0ee
--- /dev/null
+++ b/meta/packages/libxml/files/no-testapi.patch
@@ -0,0 +1,51 @@
+--- /tmp/Makefile.am 2005-11-13 14:33:15.844432536 +0100
++++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
+@@ -8,7 +8,7 @@
+
+ noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
+ testThreads testC14N testAutomata testRegexp \
+- testReader testapi testModule runtest runsuite
++ testReader testModule runtest runsuite
+
+ bin_PROGRAMS = xmllint xmlcatalog
+
+@@ -135,20 +135,9 @@
+ testdso_la_LDFLAGS = -module -rpath $(libdir)
+
+ # that one forces the rebuild when "make rebuild" is run on doc/
+-rebuild_testapi:
+- -@(if [ "$(PYTHON)" != "" ] ; then \
+- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+
+ # that one is just to make sure it is rebuilt if missing
+ # but adding the dependances generate mess
+-testapi.c:
+- -@(if [ "$(PYTHON)" != "" ] ; then \
+- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
+-
+-testapi_SOURCES=testapi.c
+-testapi_LDFLAGS =
+-testapi_DEPENDENCIES = $(DEPS)
+-testapi_LDADD= $(LDADDS)
+
+ #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
+ #testOOM_LDFLAGS =
+@@ -169,9 +158,6 @@
+ @echo '## Go get a cup of coffee it is gonna take a while ...'
+ $(MAKE) CHECKER='valgrind' tests
+
+-APItests: testapi$(EXEEXT)
+- @echo "## Running the API regression tests this may take a little while"
+- -@($(CHECKER) $(top_builddir)/testapi -q)
+
+ HTMLtests : testHTML$(EXEEXT)
+ @(echo > .memdump)
+@@ -1116,7 +1102,7 @@
+ dist-test: distdir
+ (mkdir -p $(distdir))
+ (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
+- tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
++ tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
+ @(rm -rf $(distdir)/xstc/Test)
+
+ cleantar: