summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/fakeroot/fakeroot-native_1.2.13.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.2.13.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.2.13.bb b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
new file mode 100644
index 0000000000..cc3dfd2231
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -0,0 +1,19 @@
+SECTION = "base"
+PR = "r0"
+include fakeroot_${PV}.bb
+inherit native
+
+SRC_URI += "file://fix-prefix.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}