summaryrefslogtreecommitdiffstats
path: root/meta/packages/automake/automake_1.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/automake/automake_1.9.3.bb')
-rw-r--r--meta/packages/automake/automake_1.9.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/automake/automake_1.9.3.bb b/meta/packages/automake/automake_1.9.3.bb
new file mode 100644
index 0000000000..fb75b83b68
--- /dev/null
+++ b/meta/packages/automake/automake_1.9.3.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r5"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
+S = "${WORKDIR}/automake-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+
+include automake.inc
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.9 ${D}${datadir}/automake
+ fi
+}