summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/meta/oh-image-extras.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/meta/oh-image-extras.bb')
-rw-r--r--meta-extras/packages/meta/oh-image-extras.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-extras/packages/meta/oh-image-extras.bb b/meta-extras/packages/meta/oh-image-extras.bb
new file mode 100644
index 0000000000..0b2ac430ea
--- /dev/null
+++ b/meta-extras/packages/meta/oh-image-extras.bb
@@ -0,0 +1,27 @@
+PR = "r9"
+
+export IMAGE_BASENAME = "oh-extras"
+
+GUI_MACHINE_CLASS ?= "none"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "\
+ task-oh \
+ task-oh-extras"
+
+RDEPENDS = "\
+ task-oh-boot \
+ task-oh-boot-extras \
+ task-oh-base \
+ task-oh-standard \
+ task-oh-testapps \
+ task-oh-devtools \
+ task-oh-extraapps \
+ ${XSERVER} "
+
+export IPKG_INSTALL = "${RDEPENDS}"
+#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image_ipk
+LICENSE = MIT