aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/zephyr-kernel/zephyr-helloworld.bb')
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-helloworld.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
index 7c0823c..84db068 100644
--- a/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
+++ b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
@@ -1,18 +1,13 @@
require zephyr-kernel.inc
require zephyr-kernel-common.inc
-inherit cmake pkgconfig deploy
+inherit deploy
ZEPHYR_SRC_DIR = "${S}/samples/hello_world"
ZEPHYR_BASE = "${S}"
OECMAKE_SOURCEPATH = "${ZEPHYR_SRC_DIR}"
-DEPENDS += "gperf-native"
-
-EXTRA_OECMAKE = " -DZEPHYR_BASE=${S} -DZEPHYR_GCC_VARIANT=yocto -DBOARD=${BOARD} -DARCH=${ARCH} -DCROSS_COMPILE=${CROSS_COMPILE} -DZEPHYR_SYSROOT=${ZEPHYR_SYSROOT} -DZEPHYR_TOOLCHAIN_VARIANT=yocto"
-export ZEPHYR_BASE="${S}"
-
do_deploy () {
- install -D ${B}/zephyr/zephyr.elf ${DEPLOYDIR}/${PN}.elf
+ install -D ${B}/zephyr/${ZEPHYR_MAKE_OUTPUT} ${DEPLOYDIR}/${PN}.elf
}
addtask deploy after do_compile