aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/zephyr-kernel/zephyr-helloworld.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
new file mode 100644
index 0000000..8900bfd
--- /dev/null
+++ b/recipes-kernel/zephyr-kernel/zephyr-helloworld.bb
@@ -0,0 +1,18 @@
+require zephyr-kernel.inc
+require zephyr-kernel-common.inc
+inherit deploy
+
+ZEPHYR_SRC_DIR = "${S}/samples/hello_world"
+ZEPHYR_BASE = "${S}"
+
+do_compile () {
+ cd ${ZEPHYR_SRC_DIR}
+ oe_runmake ${ZEPHYR_MAKE_ARGS}
+}
+
+do_deploy () {
+ install -D samples/hello_world/outdir/${BOARD}/zephyr.elf ${DEPLOYDIR}/${PN}.elf
+ install -D samples/hello_world/outdir/${BOARD}/zephyr.bin ${DEPLOYDIR}/${PN}.bin
+}
+
+addtask deploy after do_compile