aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/0001-versal_fw-Fixup-core-makefiles.patch2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/fix-xil-assert-filename.patch26
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/makefile-skip-copy_bsp.sh.patch2
3 files changed, 29 insertions, 1 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/0001-versal_fw-Fixup-core-makefiles.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/0001-versal_fw-Fixup-core-makefiles.patch
index 4bc191c1..cbe0c4e5 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/0001-versal_fw-Fixup-core-makefiles.patch
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/0001-versal_fw-Fixup-core-makefiles.patch
@@ -8,6 +8,8 @@ additional variables that may not be appropriate to do on the regular
command line build version. This patch preserves the default while
allowing it to be overriden as necessary.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
---
lib/sw_apps/versal_plm/misc/versal/Makefile | 6 ++++--
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/fix-xil-assert-filename.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/fix-xil-assert-filename.patch
new file mode 100644
index 00000000..2f7af0e9
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/fix-xil-assert-filename.patch
@@ -0,0 +1,26 @@
+Fix __FILENAME__ definition
+
+This fixes the error:
+
+| <command-line>: error: passing argument 1 of 'Xil_Assert' makes pointer from integer without a cast [-Wint-conversion]
+| .../work-shared/embeddedsw-2024.2+git-r0/source/git/lib/bsp/standalone/src/common/xil_assert.h:123:20: note: in expansion of macro '__FILENAME__'
+| 123 | Xil_Assert(__FILENAME__, __LINE__); \
+| | ^~~~~~~~~~~~
+
+Upstream-Status: Pending
+
+Signed-off-by: Mark Hatle <mark.hatle@amd.com>
+
+diff --git a/cmake/Findcommon.cmake b/cmake/Findcommon.cmake
+index c856d408fb..acac2e8fcc 100644
+--- a/cmake/Findcommon.cmake
++++ b/cmake/Findcommon.cmake
+@@ -11,7 +11,7 @@ endif()
+ if("${CMAKE_HOST_NAME}" STREQUAL "Linux")
+ add_compile_options("-D__FILENAME__=\"$(subst ${CMAKE_SOURCE_DIR}/,,$(abspath $<))\"")
+ else()
+- add_compile_options("-D__FILENAME__='__FILE__'")
++ add_compile_options("-D__FILENAME__=__FILE__")
+ endif()
+ set (CMAKE_INSTALL_LIBDIR "lib")
+ function (collector_create name base)
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/makefile-skip-copy_bsp.sh.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/makefile-skip-copy_bsp.sh.patch
index 4ce521cd..3f7bb7a8 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/makefile-skip-copy_bsp.sh.patch
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/makefile-skip-copy_bsp.sh.patch
@@ -6,7 +6,7 @@ Subject: [PATCH] Prevent makefile from calling copy_bsp.sh
If we call copy_bsp.sh we will undo any manual compliation steps we
have already done. Avoid this.
-YP integration specific
+Upstream-Status: Inappropriate [YP integration specific]
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
---