aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
new file mode 100644
index 00000000..6a23dc47
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
@@ -0,0 +1,20 @@
+# QEMU for the Kria SOM requires a section from the FSBL to be extracted
+
+PMU_CONF_NAME ?= "pmu-conf"
+PMU_CONF_BASE_NAME ?= "${PMU_CONF_NAME}-${PKGE}-${PKGV}-${PKGR}-${MACHINE}${IMAGE_VERSION_SUFFIX}"
+
+# Required so we can run objcopy in do_compile
+DEPENDS:append:zynqmp = " virtual/${TARGET_PREFIX}binutils"
+
+do_compile:append:zynqmp () {
+ if [ -z "${SYSTEM_DTFILE}" ]; then
+ ${OBJCOPY} --dump-section .sys_cfg_data=${B}/${PMU_CONF_NAME}.bin ${B}/${ESW_COMPONENT}
+ fi
+}
+
+do_deploy:append:zynqmp () {
+ if [ -z "${SYSTEM_DTFILE}" ]; then
+ install -Dm 0644 ${B}/${PMU_CONF_NAME}.bin ${DEPLOYDIR}/${PMU_CONF_BASE_NAME}.bin
+ ln -s ${PMU_CONF_BASE_NAME}.bin ${DEPLOYDIR}/${PMU_CONF_NAME}.bin
+ fi
+}