aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch35
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb1
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb1
7 files changed, 41 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch
new file mode 100644
index 00000000..072691d8
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch
@@ -0,0 +1,35 @@
+From 7b5cd70e8d77f5df345a2f1a29e09a51af248040 Mon Sep 17 00:00:00 2001
+From: Rajan Vaja <rajan.vaja@xilinx.com>
+Date: Fri, 26 Feb 2021 02:30:28 -0800
+Subject: [PATCH] versal_psmfw: misc: Update mcpu version in Makefile
+
+Use -mcpu=v10.0 instead of -mcpu=v as -mcpu=v is not defined and
+PSM is using v10.0.
+
+Signed-off-by: Rajan Vaja <rajan.vaja@xilinx.com>
+Acked-by: Nicole Baze <nicole.baze@xilinx.com>
+---
+ lib/sw_apps/versal_psmfw/misc/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/sw_apps/versal_psmfw/misc/Makefile b/lib/sw_apps/versal_psmfw/misc/Makefile
+index 2164c19f03..02d85e492e 100644
+--- a/lib/sw_apps/versal_psmfw/misc/Makefile
++++ b/lib/sw_apps/versal_psmfw/misc/Makefile
+@@ -41,11 +41,11 @@ $(PROCESSOR)/lib/libxil.a: $(PROCESSOR)/lib/libxil_init.a
+
+ %/make.include: $(if $(wildcard $(PROCESSOR)/lib/libxil_init.a),$(PROCESSOR)/lib/libxil.a,)
+ @echo "Running Make include in $(subst /make.include,,$@)"
+- $(MAKE) -C $(subst /make.include,,$@) -s include "SHELL=$(SHELL)" "COMPILER=$(COMPILER)" "ASSEMBLER=$(ASSEMBLER)" "ARCHIVER=$(ARCHIVER)" "COMPILER_FLAGS= -O2 -c -mcpu=v -mlittle-endian -mxl-barrel-shift -mxl-pattern-compare" "EXTRA_COMPILER_FLAGS=-g -ffunction-sections -fdata-sections -Wall -Wextra"
++ $(MAKE) -C $(subst /make.include,,$@) -s include "SHELL=$(SHELL)" "COMPILER=$(COMPILER)" "ASSEMBLER=$(ASSEMBLER)" "ARCHIVER=$(ARCHIVER)" "COMPILER_FLAGS= -O2 -c -mcpu=v10.0 -mlittle-endian -mxl-barrel-shift -mxl-pattern-compare" "EXTRA_COMPILER_FLAGS=-g -ffunction-sections -fdata-sections -Wall -Wextra"
+
+ %/make.libs: include
+ @echo "Running Make libs in $(subst /make.libs,,$@)"
+- $(MAKE) -C $(subst /make.libs,,$@) -s libs "SHELL=$(SHELL)" "COMPILER=$(COMPILER)" "ASSEMBLER=$(ASSEMBLER)" "ARCHIVER=$(ARCHIVER)" "COMPILER_FLAGS= -O2 -c -mcpu=v -mlittle-endian -mxl-barrel-shift -mxl-pattern-compare" "EXTRA_COMPILER_FLAGS=-g -ffunction-sections -fdata-sections -Wall -Wextra"
++ $(MAKE) -C $(subst /make.libs,,$@) -s libs "SHELL=$(SHELL)" "COMPILER=$(COMPILER)" "ASSEMBLER=$(ASSEMBLER)" "ARCHIVER=$(ARCHIVER)" "COMPILER_FLAGS= -O2 -c -mcpu=v10.0 -mlittle-endian -mxl-barrel-shift -mxl-pattern-compare" "EXTRA_COMPILER_FLAGS=-g -ffunction-sections -fdata-sections -Wall -Wextra"
+
+ %/make.clean:
+ $(MAKE) -C $(subst /make.clean,,$@) -s clean
+--
+2.17.1
+
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
index a72b055d..b8a920ae 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
@@ -5,6 +5,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
index e1c2873c..b625b332 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
@@ -8,6 +8,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
index 09c7492a..12fc5c76 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
@@ -5,6 +5,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
index f8975141..17ce7693 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
@@ -8,6 +8,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
index e3125c47..39353fdf 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
@@ -5,6 +5,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
index 21ef13b5..6d34e723 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
@@ -8,6 +8,7 @@ SRC_URI += " \
file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
file://0001-sw_apps-versal_plm-Changes-to-ensure-versionless-bui.patch \
file://0001-versal_psmfw-misc-Update-makefile-for-version-less-b.patch \
+ file://0001-versal_psmfw-misc-Update-mcpu-version-in-Makefile.patch \
file://zynqmp_pmufw-fixup.patch \
file://makefile-skip-copy_bsp.sh.patch \
"