aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-networking/slirp4netns/slirp4netns_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/slirp4netns/slirp4netns_git.bb')
-rw-r--r--recipes-networking/slirp4netns/slirp4netns_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-networking/slirp4netns/slirp4netns_git.bb b/recipes-networking/slirp4netns/slirp4netns_git.bb
new file mode 100644
index 00000000..33a5636a
--- /dev/null
+++ b/recipes-networking/slirp4netns/slirp4netns_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "User-mode networking for unprivileged network namespaces."
+DESCRIPTION = "slirp4netns allows connecting a network namespace to the \
+Internet in a completely unprivileged way, by connecting a TAP device in a \
+network namespace to the usermode TCP/IP stack ("slirp")."
+
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1e2efd29c201480c6be2744d9edade26"
+
+SRCREV = "323aa69a68362a432f15d5e8050e74a0637aaf1e"
+SRC_URI = "git://github.com/rootless-containers/slirp4netns.git;nobranch=1;protocol=https"
+
+PV = "1.2.0+git"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES ?= "seccomp"
+
+DEPENDS = "glib-2.0 libcap libseccomp libslirp"
+
+S = "${WORKDIR}/git"
+
+RRECOMMENDS:${PN} += "kernel-module-tun"
+
+inherit autotools pkgconfig