aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/kvmtool/files/external-crosscompiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/kvmtool/files/external-crosscompiler.patch')
-rw-r--r--recipes-extended/kvmtool/files/external-crosscompiler.patch30
1 files changed, 15 insertions, 15 deletions
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch
index ab030c73..e27ee34b 100644
--- a/recipes-extended/kvmtool/files/external-crosscompiler.patch
+++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch
@@ -1,4 +1,4 @@
-From b89ba4256cb6074aee74ea5386bc5ca8e75d4653 Mon Sep 17 00:00:00 2001
+From 91b7123682c67ec8b0c50147c9ebd59efa563f26 Mon Sep 17 00:00:00 2001
From: Stefan Agner <stefan@agner.ch>
Date: Tue, 6 Sep 2016 11:51:40 -0700
Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool
@@ -13,13 +13,13 @@ be linked against the cross-compiled libfdt library.
Makefile | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)
-diff --git a/Makefile b/Makefile
-index 35bb118..3787df2 100644
---- a/Makefile
-+++ b/Makefile
-@@ -18,12 +18,6 @@ export E Q
- include config/utilities.mak
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -19,12 +19,6 @@
include config/feature-tests.mak
+ -include $(OUTPUT)KVMTOOLS-VERSION-FILE
-CC := $(CROSS_COMPILE)gcc
-CFLAGS :=
@@ -30,12 +30,12 @@ index 35bb118..3787df2 100644
FIND := find
CSCOPE := cscope
TAGS := ctags
-@@ -319,7 +313,7 @@ $(warning No static libc found. Skipping guest init)
- endif
-
- ifeq (y,$(ARCH_WANT_LIBFDT))
-- ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y)
-+ ifneq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y)
- $(error No libfdt found. Please install libfdt-dev package)
- else
+@@ -367,7 +361,7 @@
+ CFLAGS_DYNOPT += -DCONFIG_HAS_LIBFDT
+ CFLAGS_STATOPT += -DCONFIG_HAS_LIBFDT
+ CFLAGS += -I $(LIBFDT_DIR)
+- else ifeq ($(call try-build,$(SOURCE_LIBFDT),$(CFLAGS),-lfdt),y)
++ else ifeq ($(call try-build,$(SOURCE_LIBFDT),$(CPPFLAGS) $(CFLAGS),-lfdt),y)
+ LIBFDT_STATIC :=
CFLAGS_DYNOPT += -DCONFIG_HAS_LIBFDT
+ CFLAGS_STATOPT += -DCONFIG_HAS_LIBFDT