aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/ipxe/ipxe_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ipxe/ipxe_git.bb')
-rw-r--r--recipes-extended/ipxe/ipxe_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-extended/ipxe/ipxe_git.bb b/recipes-extended/ipxe/ipxe_git.bb
index 74de9cb1..08ed519a 100644
--- a/recipes-extended/ipxe/ipxe_git.bb
+++ b/recipes-extended/ipxe/ipxe_git.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Open source network boot firmware"
HOMEPAGE = "http://ipxe.org"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native xz"
LIC_FILES_CHKSUM = "file://../COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://../COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263
COMPATIBLE_HOST:class-target = '(x86_64|i.86).*-(linux|freebsd.*)'
SRCREV = "18dc73d27edb55ebe9cb13c58d59af3da3bd374b"
-PV = "1.20.1+git${SRCPV}"
+PV = "1.20.1+git"
PR = "r0"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
@@ -23,13 +23,13 @@ SRC_URI = " \
FILES:${PN} = "/usr/share/firmware/*.rom"
-EXTRA_OEMAKE = " \
+EXTRA_OEMAKE = ' \
ISOLINUX_BIN="${STAGING_DIR_TARGET}/usr/share/syslinux/isolinux.bin" \
CROSS_COMPILE="${TARGET_PREFIX}" \
EXTRA_HOST_CFLAGS="${BUILD_CFLAGS}" \
EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}" \
NO_WERROR="1" \
-"
+'
S = "${WORKDIR}/git/src"
@@ -44,3 +44,5 @@ do_install() {
install -d ${D}/usr/share/firmware
install ${S}/bin/*.rom ${D}/usr/share/firmware/
}
+
+TOOLCHAIN = "gcc"