aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/diod/diod_1.0.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/diod/diod_1.0.24.bb')
-rw-r--r--recipes-extended/diod/diod_1.0.24.bb18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-extended/diod/diod_1.0.24.bb b/recipes-extended/diod/diod_1.0.24.bb
index 508303a8..6019fbfb 100644
--- a/recipes-extended/diod/diod_1.0.24.bb
+++ b/recipes-extended/diod/diod_1.0.24.bb
@@ -5,26 +5,24 @@ Although the kernel client supports several 9P variants, diod only supports \
9P2000.L, and only in its feature-complete form, as it appeared in 2.6.38."
SECTION = "console/network"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-PV = "1.0.24+git${SRCPV}"
-SRCREV = "0ea3fe3d829b5085307cd27a512708d99ef48199"
+PV = "1.0.24+git"
+SRCREV = "b4b5e8e00ed11b21d7fcf05a080dc054a8eac2d6"
SRC_URI = "git://github.com/chaos/diod.git;protocol=https;branch=master \
file://diod \
file://diod.conf \
- file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \
- file://0002-auto.diod.in-remove-bashisms.patch \
- file://0001-diod-ops.c-add-header-file-for-makedev.patch \
- file://0001-drod-add-option-to-config-systemddir.patch \
- "
+ file://0001-build-Find-lua-with-pkg-config.patch \
+ file://0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch \
+ "
DEPENDS = "libcap ncurses tcp-wrappers lua"
-EXTRA_OECONF = "--with-systemddir=${systemd_unitdir}/system"
+EXTRA_OEMAKE += "systemddir=${systemd_unitdir}/system"
S = "${WORKDIR}/git"
-inherit autotools systemd
+inherit autotools pkgconfig systemd
do_install:append () {
# install our init based on start-stop-daemon