aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch')
-rw-r--r--recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch b/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch
index 5c9c1e6f..e5b214fe 100644
--- a/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch
+++ b/recipes-extended/cloud-init/cloud-init/0001-setup.py-check-for-install-anywhere-in-args.patch
@@ -11,6 +11,8 @@ So rather than checking for install to be argv[1], we check for it
anywhere in the arguments are trigger the template replacement to
happen.
+Upstream-Status: Inappropriate [embedded specific]
+
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
setup.py | 2 +-
@@ -20,11 +22,11 @@ Index: git/setup.py
===================================================================
--- git.orig/setup.py
+++ git/setup.py
-@@ -87,7 +87,7 @@
+@@ -60,7 +60,7 @@
+ that files are different outside of the debian directory."""
- # older versions of tox use bdist (xenial), and then install from there.
# newer versions just use install.
-- if not (sys.argv[1] == "install" or sys.argv[1].startswith("bdist*")):
+- if "install" not in sys.argv:
+ if not ('install' in sys.argv or sys.argv[1].startswith('bdist*')):
return template