aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/kata-containers
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/kata-containers')
-rw-r--r--recipes-core/kata-containers/kata-agent_git.bb6
-rw-r--r--recipes-core/kata-containers/kata-proxy_git.bb5
-rw-r--r--recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch2
-rw-r--r--recipes-core/kata-containers/kata-runtime_git.bb4
-rw-r--r--recipes-core/kata-containers/kata-shim_git.bb4
5 files changed, 16 insertions, 5 deletions
diff --git a/recipes-core/kata-containers/kata-agent_git.bb b/recipes-core/kata-containers/kata-agent_git.bb
index ca552b9f..de28235c 100644
--- a/recipes-core/kata-containers/kata-agent_git.bb
+++ b/recipes-core/kata-containers/kata-agent_git.bb
@@ -5,11 +5,13 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/agent/LICENSE;md5=86d3
GO_IMPORT = "github.com/kata-containers/agent"
SRCREV = "e03f7d7453fabffb17e1540f28666c26178d3cbf"
-SRC_URI = "git://${GO_IMPORT}.git;branch=master \
+SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
"
RDEPENDS:${PN}-dev:append = "bash"
+SKIP_RECIPE[kata-agent] ?= "kata containers are currently broken, patches accepted"
+
S = "${WORKDIR}/git"
inherit go
@@ -36,4 +38,4 @@ do_install() {
deltask compile_ptest_base
-FILES:${PN} += "${systemd_unitdir}/*" \ No newline at end of file
+FILES:${PN} += "${systemd_unitdir}/*"
diff --git a/recipes-core/kata-containers/kata-proxy_git.bb b/recipes-core/kata-containers/kata-proxy_git.bb
index cbce8241..d835e4d2 100644
--- a/recipes-core/kata-containers/kata-proxy_git.bb
+++ b/recipes-core/kata-containers/kata-proxy_git.bb
@@ -5,9 +5,12 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/proxy/LICENSE;md5=86d3
GO_IMPORT = "github.com/kata-containers/proxy"
SRCREV = "1148847739f9a9f47b92e34e4f309dc109d4dba9"
-SRC_URI = "git://${GO_IMPORT}.git;branch=master \
+SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
"
+
+SKIP_RECIPE[kata-proxy] ?= "kata containers are currently broken, patches accepted"
+
RDEPENDS:${PN}-dev:append = "bash"
S = "${WORKDIR}/git"
diff --git a/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch b/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch
index b92abeb3..dde63478 100644
--- a/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch
+++ b/recipes-core/kata-containers/kata-runtime/0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch
@@ -3,6 +3,8 @@ From: Bruce Ashfield <bruce.ashfield@gmail.com>
Date: Wed, 7 Oct 2020 23:29:52 -0400
Subject: [PATCH] makefile: allow SKIP_GO_VERSION_CHECK to be overriden
+Upstream-Status: Inappropriate [embedded specific]
+
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
Makefile | 2 +-
diff --git a/recipes-core/kata-containers/kata-runtime_git.bb b/recipes-core/kata-containers/kata-runtime_git.bb
index c7f156f0..c0d7c4cb 100644
--- a/recipes-core/kata-containers/kata-runtime_git.bb
+++ b/recipes-core/kata-containers/kata-runtime_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/runtime/LICENSE;md5=86
GO_IMPORT = "github.com/kata-containers/runtime"
SRCREV = "04c77eb20e9bd603cab5c711bcbe7c69db58b040"
-SRC_URI = "git://${GO_IMPORT}.git;branch=master \
+SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
file://0001-makefile-allow-SKIP_GO_VERSION_CHECK-to-be-overriden.patch \
"
RDEPENDS:${PN}-dev:append = "bash"
@@ -19,6 +19,8 @@ RDEPENDS:${PN} = " \
"
DEPENDS += "yq-native"
+SKIP_RECIPE[kata-runtime] ?= "kata containers are currently broken, patches accepted"
+
S = "${WORKDIR}/git"
inherit go
diff --git a/recipes-core/kata-containers/kata-shim_git.bb b/recipes-core/kata-containers/kata-shim_git.bb
index 467df261..8a7cb78a 100644
--- a/recipes-core/kata-containers/kata-shim_git.bb
+++ b/recipes-core/kata-containers/kata-shim_git.bb
@@ -5,9 +5,11 @@ LIC_FILES_CHKSUM = "file://src/github.com/kata-containers/shim/LICENSE;md5=86d3f
GO_IMPORT = "github.com/kata-containers/shim"
SRCREV = "bcc35aeca3ef6fa0976005c9e93525906aefed2f"
-SRC_URI = "git://${GO_IMPORT}.git;branch=master \
+SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
"
+SKIP_RECIPE[kata-shim] ?= "kata containers are currently broken, patches accepted"
+
RDEPENDS:${PN}-dev:append = "bash"
S = "${WORKDIR}/git"