aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/busybox')
-rw-r--r--recipes-core/busybox/busybox-initrd.bb (renamed from recipes-core/busybox/busybox-initrd_1.35.0.bb)14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd_1.35.0.bb b/recipes-core/busybox/busybox-initrd.bb
index 6108e9af..513ed135 100644
--- a/recipes-core/busybox/busybox-initrd_1.35.0.bb
+++ b/recipes-core/busybox/busybox-initrd.bb
@@ -1,5 +1,19 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
+def get_busybox_pv(d):
+ import re
+ corebase = d.getVar('COREBASE')
+ bb_dir = os.path.join(corebase, 'meta', 'recipes-core', 'busybox')
+ if os.path.isdir(bb_dir):
+ re_bb_name = re.compile(r"busybox_([0-9.]*)\.bb")
+ for bb_file in os.listdir(bb_dir):
+ result = re_bb_name.match(bb_file)
+ if result:
+ return result.group(1)
+ bb.fatal("Cannot find busybox recipe in %s" % bb_dir)
+
+PV := "${@get_busybox_pv(d)}"
+
require recipes-core/busybox/busybox_${PV}.bb
SRC_URI += "file://init.cfg \