aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/umoci/umoci_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/umoci/umoci_git.bb')
-rw-r--r--recipes-containers/umoci/umoci_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-containers/umoci/umoci_git.bb b/recipes-containers/umoci/umoci_git.bb
index b1a17280..2ed0af7d 100644
--- a/recipes-containers/umoci/umoci_git.bb
+++ b/recipes-containers/umoci/umoci_git.bb
@@ -6,17 +6,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
RDEPENDS:${PN} = "skopeo"
RDEPENDS:${PN}:class-native = ""
-SRCREV_umoci = "758044fc26ad65eb900143e90d1e22c2d6e4484d"
+SRCREV_umoci = "33ec00665c66321f1b1f34ca7e6f370ac35c1233"
SRC_URI = "git://github.com/opencontainers/umoci.git;branch=main;name=umoci;destsuffix=github.com/opencontainers/umoci;protocol=https \
"
-PV = "v0.4.7-dev+git${SRCPV}"
+PV = "v0.4.7+git"
S = "${WORKDIR}/github.com/opencontainers/umoci"
GO_IMPORT = "github.com/opencontainers/umoci"
inherit goarch
inherit go
+COMPATIBLE_HOST = "^(?!mips).*"
+
# This disables seccomp and apparmor, which are on by default in the
# go package.
EXTRA_OEMAKE="BUILDTAGS=''"
@@ -40,6 +42,8 @@ do_compile:class-native () {
export GOPATH="${WORKDIR}/git/"
export GO111MODULE=off
+ export STATIC_BUILD_FLAGS="-trimpath"
+
cd ${S}
# why static ? patchelf will be run on dynamic binaries and it breaks
@@ -61,11 +65,12 @@ do_compile() {
export CGO_ENABLED="1"
export CFLAGS=""
export LDFLAGS=""
- export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
- export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
+ export CGO_CFLAGS="${TARGET_CFLAGS}"
+ export CGO_LDFLAGS="${TARGET_LDFLAGS}"
export GO111MODULE=off
+ export BUILD_FLAGS="-trimpath"
cd ${S}
oe_runmake umoci