aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/go-errors/go-errors_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/go-errors/go-errors_git.bb')
-rw-r--r--recipes-containers/go-errors/go-errors_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-containers/go-errors/go-errors_git.bb b/recipes-containers/go-errors/go-errors_git.bb
index f1d7ef3b..1236bb7b 100644
--- a/recipes-containers/go-errors/go-errors_git.bb
+++ b/recipes-containers/go-errors/go-errors_git.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=6fe682a02df52c6653f33bd0f
SRCNAME = "errors"
PKG_NAME = "github.com/pkg/${SRCNAME}"
-SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
+SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
SRCREV = "5dd12d0cfe7f152f80558d591504ce685299311e"
-PV = "v0.8.1+git${SRCPV}"
+PV = "v0.8.1+git"
S = "${WORKDIR}/git"
@@ -18,6 +18,8 @@ S = "${WORKDIR}/git"
do_compile() {
}
+inherit meta-virt-depreciated-warning
+
do_install() {
install -d ${D}${prefix}/local/go/src/${PKG_NAME}
for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go" -not -path "*/.tool/*"); do