aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/docker-moby_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/docker-moby_git.bb')
-rw-r--r--recipes-containers/docker/docker-moby_git.bb36
1 files changed, 24 insertions, 12 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index b8dfbc44..0abb0b3f 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -27,34 +27,46 @@ DESCRIPTION = "Linux container runtime \
# the curated docker-ce repository. This allows compatibility and
# functional equivalence, while allowing new features to be more
# easily added.
-# - This could be called "docker-moby" or just "moby" in the future, but
-# that would require the creation of a virtual/docker dependency, which
-# is possible, but overkill at the moment (while we wait for the upstream
-# to stop changing).
# - The common components of this recipe and docker-ce do need to be moved
# to a docker.inc recipe
+#
+# Packaging details:
+#
+# https://github.com/docker/docker-ce-packaging.git
+# common.mk:
+# DOCKER_CLI_REPO ?= https://github.com/docker/cli.git
+# DOCKER_ENGINE_REPO ?= https://github.com/docker/docker.git
+# REF ?= HEAD
+# DOCKER_CLI_REF ?= $(REF)
+# DOCKER_ENGINE_REF ?= $(REF)
+#
+# These follow the tags for our releases in the listed repositories
+# so we get that tag, and make it our SRCREVS:
+#
-SRCREV_moby = "7bd682c48c076fd398275925a18394eba46cb8d0"
-SRCREV_libnetwork = "64b7a4574d1426139437d20e81c0b6d391130ec8"
-SRCREV_cli = "b485636f4b90ed5a91a1f403e65ffced469c641a"
+SRCREV_moby = "f417435e5f6216828dec57958c490c4f8bae4f98"
+SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c"
+SRCREV_cli = "01f933261885c0126edb3f47fd56d048ae31265a"
SRCREV_FORMAT = "moby_libnetwork"
SRC_URI = "\
- git://github.com/moby/moby.git;branch=20.10;name=moby;protocol=https \
+ git://github.com/moby/moby.git;branch=25.0;name=moby;protocol=https \
git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \
- git://github.com/docker/cli;branch=20.10;name=cli;destsuffix=git/cli;protocol=https \
+ git://github.com/docker/cli;branch=25.0;name=cli;destsuffix=git/cli;protocol=https \
file://docker.init \
file://0001-libnetwork-use-GO-instead-of-go.patch \
file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \
- file://0001-dynbinary-use-go-cross-compiler.patch \
+ file://0001-dynbinary-use-go-cross-compiler.patch;patchdir=src/import \
"
+DOCKER_COMMIT = "${SRCREV_moby}"
+
require docker.inc
# Apache-2.0 for docker
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
-DOCKER_VERSION = "20.10.10"
+DOCKER_VERSION = "25.0.3"
PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
-CVE_PRODUCT = "docker"
+CVE_PRODUCT = "docker mobyproject:moby"