aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-o/cri-o_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/cri-o/cri-o_git.bb')
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 9a847ef2..4e17a7cd 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -14,10 +14,9 @@ At a high level, we expect the scope of cri-o to be restricted to the following
- Resource isolation as required by the CRI \
"
-SRCREV_cri-o = "e3dfe61cafa3922bf7ad9b0a2ac3dc7e6873209b"
+SRCREV_cri-o = "5aff11c7c1afdc785adafd7da3c3f2a6ac51b88d"
SRC_URI = "\
- git://github.com/kubernetes-sigs/cri-o.git;branch=release-1.22;name=cri-o;protocol=https \
- file://0001-Makefile-force-symlinks.patch \
+ git://github.com/kubernetes-sigs/cri-o.git;branch=release-1.30;name=cri-o;protocol=https \
file://crio.conf \
"
@@ -27,7 +26,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2
GO_IMPORT = "import"
-PV = "1.22.1+git${SRCREV_cri-o}"
+PV = "1.30.0+git${SRCREV_cri-o}"
inherit features_check
REQUIRED_DISTRO_FEATURES ?= "seccomp"
@@ -39,24 +38,25 @@ DEPENDS = " \
ostree \
libdevmapper \
libseccomp \
- libselinux \
"
RDEPENDS:${PN} = " \
cni \
libdevmapper \
"
-PNBLACKLIST[cri-o] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', bb.utils.contains('BBFILE_COLLECTIONS', 'selinux', '', 'Depends on libselinux from meta-selinux which is not included', d), 'Depends on libseccomp from meta-security which is not included', d)}"
+PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
+PACKAGECONFIG[selinux] = ",,libselinux"
PACKAGES =+ "${PN}-config"
-RDEPENDS:${PN} += " virtual-containerd virtual-runc"
+RDEPENDS:${PN} += " ${VIRTUAL-RUNTIME_container_runtime}"
RDEPENDS:${PN} += " e2fsprogs-mke2fs conmon util-linux iptables conntrack-tools"
inherit systemd
inherit go
inherit goarch
inherit pkgconfig
+inherit container-host
EXTRA_OEMAKE="BUILDTAGS=''"
@@ -96,6 +96,8 @@ do_install() {
install -m 0644 ${S}/src/import/contrib/systemd/crio.service ${D}${systemd_unitdir}/system/
install -m 0644 ${S}/src/import/contrib/systemd/crio-shutdown.service ${D}${systemd_unitdir}/system/
install -m 0644 ${S}/src/import/contrib/systemd/crio-wipe.service ${D}${systemd_unitdir}/system/
+
+ install -d ${D}${localstatedir}/lib/crio
}
FILES:${PN}-config = "${sysconfdir}/crio/config/*"
@@ -106,7 +108,7 @@ FILES:${PN} += "/usr/share/containers/oci/hooks.d"
# don't clobber hooks.d
ALLOW_EMPTY:${PN} = "1"
-INSANE_SKIP:${PN} += "ldflags already-stripped"
+INSANE_SKIP:${PN} += "ldflags already-stripped textrel"
deltask compile_ptest_base