aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch')
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch21
1 files changed, 9 insertions, 12 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
index 7f4d7518..63498a86 100644
--- a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch
@@ -12,27 +12,24 @@ packages, we end up with errors like:
recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link:
cannot open file : open : no such file or directory
-Upstream-Status: Inappropriate: specific to OE go configuration and build
+Upstream-Status: Inappropriate [specific to OE go configuration and build]
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
-diff --git git.orig/src/import/Makefile git.orig/src/import/Makefile
-index c61418e60..54a10eb42 100644
---- git.orig/src/import/Makefile
-+++ git.orig/src/import/Makefile
-@@ -112,7 +112,8 @@ endif
- GOPATHS=$(shell echo ${GOPATH} | tr ":" "\n" | tr ";" "\n")
+Index: containerd/Makefile
+===================================================================
+--- containerd.orig/Makefile
++++ containerd/Makefile
+@@ -129,7 +129,8 @@
+ GOPATHS=$(shell $(GO) env GOPATH | tr ":" "\n" | tr ";" "\n")
TESTFLAGS_RACE=
--GO_BUILD_FLAGS=
+-GO_BUILD_FLAGS ?=
+# allow flags to be exported and picked up.
-+# GO_BUILD_FLAGS=
++# GO_BUILD_FLAGS ?=
# See Golang issue re: '-trimpath': https://github.com/golang/go/issues/13809
GO_GCFLAGS=$(shell \
set -- ${GOPATHS}; \
---
-2.19.1
-