aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ipc-transport-common-rtos_git.bb2
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb4
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-test_git.bb6
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss.inc2
-rw-r--r--recipes-ti/ipc/ipc-transport-srio-rtos_git.bb4
-rw-r--r--recipes-ti/ipc/ipc-transport-srio.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc20
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb6
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc4
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb6
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc16
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb36
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb24
-rw-r--r--recipes-ti/ipc/ti-rpmsg-char.inc2
14 files changed, 67 insertions, 67 deletions
diff --git a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb
index 6fec0f0d..ade78022 100644
--- a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb
+++ b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb
@@ -20,4 +20,4 @@ do_install () {
cp -r ${S} ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66
}
-FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example/*"
+FILES:${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example/*"
diff --git a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb
index 6655ab7e..2dffc11e 100644
--- a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb
+++ b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb
@@ -9,7 +9,7 @@ COMPATIBLE_MACHINE = "k2hk|k2l|k2e"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-DEPENDS_append = " qmss-lld-rtos \
+DEPENDS:append = " qmss-lld-rtos \
cppi-lld-rtos \
ti-ipc-rtos \
ipc-transport-common-rtos \
@@ -20,4 +20,4 @@ IPC_TRANSPORT_QMSS_DESTSUFFIX = "git/c66/qmss"
S = "${WORKDIR}/${IPC_TRANSPORT_QMSS_DESTSUFFIX}"
export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}"
-XDCPATH_append = ";${IPC_INSTALL_DIR}/packages"
+XDCPATH:append = ";${IPC_INSTALL_DIR}/packages"
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
index 3561ef95..158d1856 100644
--- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
+++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
@@ -10,9 +10,9 @@ DEPENDS = "ipc-transport-qmss ti-ipc"
CHOICELIST = "yes no"
-DEVICELIST_k2hk = "k2h k2k"
-DEVICELIST_k2e = "k2e"
-DEVICELIST_k2l = "k2l"
+DEVICELIST:k2hk = "k2h k2k"
+DEVICELIST:k2e = "k2e"
+DEVICELIST:k2l = "k2l"
do_compile () {
# Now build the test code
diff --git a/recipes-ti/ipc/ipc-transport-qmss.inc b/recipes-ti/ipc/ipc-transport-qmss.inc
index f029656e..04705269 100644
--- a/recipes-ti/ipc/ipc-transport-qmss.inc
+++ b/recipes-ti/ipc/ipc-transport-qmss.inc
@@ -3,7 +3,7 @@ LICENSE = "BSD-3-Clause"
require ipc-transport.inc
-INC_PR_append = ".1"
+INC_PR:append = ".1"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
diff --git a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb
index 3f96598f..52720916 100644
--- a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb
+++ b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://TransportSrio.xdc;beginline=1;endline=35;md5=4d466471
COMPATIBLE_MACHINE = "k2hk"
-DEPENDS_append = " qmss-lld-rtos \
+DEPENDS:append = " qmss-lld-rtos \
cppi-lld-rtos \
srio-lld-rtos \
ti-ipc-rtos \
@@ -19,4 +19,4 @@ IPC_TRANSPORT_SRIO_DESTSUFFIX = "git/c66/srio"
S = "${WORKDIR}/${IPC_TRANSPORT_SRIO_DESTSUFFIX}"
export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}"
-XDCPATH_append = ";${IPC_INSTALL_DIR}/packages"
+XDCPATH:append = ";${IPC_INSTALL_DIR}/packages"
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc
index 6c477388..89425703 100644
--- a/recipes-ti/ipc/ipc-transport-srio.inc
+++ b/recipes-ti/ipc/ipc-transport-srio.inc
@@ -3,7 +3,7 @@ LICENSE = "BSD-3-Clause"
require ipc-transport.inc
-INC_PR_append = ".1"
+INC_PR:append = ".1"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 449903f1..a32aad09 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -3,18 +3,18 @@ INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_HOST ?= "null"
-COMPATIBLE_HOST_ti-soc = "(.*)"
+COMPATIBLE_HOST:ti-soc = "(.*)"
PLATFORM = "UNKNOWN"
-PLATFORM_omap5-evm = "OMAP54XX"
-PLATFORM_dra7xx = "DRA7XX"
-PLATFORM_k2hk = "TCI6638"
-PLATFORM_k2l = "TCI6630"
-PLATFORM_k2e = "66AK2E"
-PLATFORM_k2g = "66AK2G"
-PLATFORM_omapl138 = "OMAPL138"
+PLATFORM:omap5-evm = "OMAP54XX"
+PLATFORM:dra7xx = "DRA7XX"
+PLATFORM:k2hk = "TCI6638"
+PLATFORM:k2l = "TCI6630"
+PLATFORM:k2e = "66AK2E"
+PLATFORM:k2g = "66AK2G"
+PLATFORM:omapl138 = "OMAPL138"
PLATFORM_c667x-evm = "C6678"
PLATFORM_c665x-evm = "C6678"
-ALT_PLATFORM_k2hk = "TCI6636"
-ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
+ALT_PLATFORM:k2hk = "TCI6636"
+ALT_PLATFORM:am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
index ab479556..81706592 100644
--- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -5,7 +5,7 @@ SRC_URI += "file://0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.pat
DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-do_compile_append() {
+do_compile:append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
@@ -27,7 +27,7 @@ do_compile_append() {
fi
}
-do_install_append() {
+do_install:append() {
cd ${S_ipc-examples}/src
if [ "${PLATFORM}" != "UNKNOWN" ]; then
@@ -46,4 +46,4 @@ do_install_append() {
fi
}
-FILES_${PN} += "${bindir}/*"
+FILES:${PN} += "${bindir}/*"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
index 022b13f0..66cd5d32 100644
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -5,9 +5,9 @@ require ti-ipc-rtos.inc
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=a52324bd5033bb49ea07bade1244ac9a"
-INSANE_SKIP_${PN} += "arch"
+INSANE_SKIP:${PN} += "arch"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index c46e5c81..bcc8674e 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -3,7 +3,7 @@ require ti-ipc-examples.inc
DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-do_compile_append() {
+do_compile:append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
@@ -21,7 +21,7 @@ do_compile_append() {
fi
}
-do_install_append() {
+do_install:append() {
if [ "${PLATFORM}" != "UNKNOWN" ]; then
# Install directory for bios examples
install -d ${D}/ipc_${IPC_VERSION}/examples/bios
@@ -41,4 +41,4 @@ do_install_append() {
fi
}
-FILES_${PN} += "ipc_*"
+FILES:${PN} += "ipc_*"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index b6b7892f..a43d6935 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -41,37 +41,37 @@ RELEASE_SUFFIX = ""
PR = "${INC_PR}.r0"
-DEPENDS_append_keystone = " ti-cgt6x-native \
+DEPENDS:append:keystone = " ti-cgt6x-native \
gcc-arm-baremetal-native \
"
-DEPENDS_append_omap-a15 = " ti-cgt6x-native \
+DEPENDS:append:omap-a15 = " ti-cgt6x-native \
ti-cgt-arm-native \
gcc-arm-baremetal-native \
"
-DEPENDS_append_omapl138 = " ti-cgt6x-native \
+DEPENDS:append:omapl138 = " ti-cgt6x-native \
"
-DEPENDS_append_c66x = " ti-cgt6x-native \
+DEPENDS:append:c66x = " ti-cgt6x-native \
"
IPC_TARGETS = ""
-IPC_TARGETS_omap-a15 = "\
+IPC_TARGETS:omap-a15 = "\
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
"
-IPC_TARGETS_omapl138 = "\
+IPC_TARGETS:omapl138 = "\
ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
-IPC_TARGETS_keystone = " \
+IPC_TARGETS:keystone = " \
gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
-IPC_TARGETS_c66x = " \
+IPC_TARGETS:c66x = " \
ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
"
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index b292d677..3439cab1 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -5,13 +5,13 @@ require ti-ipc-rtos.inc
DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
PACKAGES =+ "${PN}-fw"
-FILES_${PN}-fw = "${base_libdir}/firmware/*"
-FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
+FILES:${PN}-fw = "${base_libdir}/firmware/*"
+FILES:${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
-INSANE_SKIP_${PN}-fw += "arch"
-INSANE_SKIP_${PN}-dev += "arch"
+INSANE_SKIP:${PN}-fw += "arch"
+INSANE_SKIP:${PN}-dev += "arch"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
IPC_PACKAGE_DIR = "${S}/ipc-package"
@@ -73,19 +73,19 @@ do_install() {
}
KFDSPNUM = "0"
-KFDSPNUM_k2hk = "8"
-KFDSPNUM_k2l = "4"
-KFDSPNUM_keystone = "1"
+KFDSPNUM:k2hk = "8"
+KFDSPNUM:k2l = "4"
+KFDSPNUM:keystone = "1"
KFPLAT = ""
-KFPLAT_k2hk = "TCI6638K2K"
-KFPLAT_k2l = "TCI6630K2L"
-KFPLAT_k2e = "C66AK2E"
-KFPLAT_k2g = "TCI66AK2G02"
+KFPLAT:k2hk = "TCI6638K2K"
+KFPLAT:k2l = "TCI6630K2L"
+KFPLAT:k2e = "C66AK2E"
+KFPLAT:k2g = "TCI66AK2G02"
ALTERNATIVE_PRIORITY = "5"
-pkg_postinst_${PN}-fw_keystone () {
+pkg_postinst:${PN}-fw:keystone () {
i=0
while [ $i -lt ${KFDSPNUM} ]; do
update-alternatives --install /lib/firmware/keystone-dsp$i-fw keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66 ${ALTERNATIVE_PRIORITY}
@@ -93,7 +93,7 @@ pkg_postinst_${PN}-fw_keystone () {
done
}
-pkg_postrm_${PN}-fw_keystone () {
+pkg_postrm:${PN}-fw:keystone () {
i=0
while [ $i -lt ${KFDSPNUM} ]; do
update-alternatives --remove keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66
@@ -101,24 +101,24 @@ pkg_postrm_${PN}-fw_keystone () {
done
}
-pkg_postinst_${PN}-fw_omap-a15 () {
+pkg_postinst:${PN}-fw:omap-a15 () {
update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}
update-alternatives --install /lib/firmware/dra7-ipu1-fw.xem4 dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4 ${ALTERNATIVE_PRIORITY}
update-alternatives --install /lib/firmware/dra7-ipu2-fw.xem4 dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4 ${ALTERNATIVE_PRIORITY}
}
-pkg_postrm_${PN}-fw_omap-a15 () {
+pkg_postrm:${PN}-fw:omap-a15 () {
update-alternatives --remove dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66
update-alternatives --remove dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66
update-alternatives --remove dra7-ipu1-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu1/test_omx_ipu1_vayu.xem4
update-alternatives --remove dra7-ipu2-fw.xem4 ipc/ti_platforms_evmDRA7XX_ipu2/test_omx_ipu2_vayu.xem4
}
-pkg_postinst_${PN}-fw_omapl138 () {
+pkg_postinst:${PN}-fw:omapl138 () {
update-alternatives --install /lib/firmware/rproc-dsp-fw rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 ${ALTERNATIVE_PRIORITY}
}
-pkg_postrm_${PN}-fw_omapl138 () {
+pkg_postrm:${PN}-fw:omapl138 () {
update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
}
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
index 425ca4e1..c3a58472 100644
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -15,20 +15,20 @@ SRC_URI += "file://tiipclad-daemon.sh \
"
DAEMON = "UNKNOWN"
-DAEMON_omap5-evm = "lad_omap54xx_smp"
-DAEMON_dra7xx = "lad_dra7xx"
-DAEMON_k2hk = "lad_tci6638"
-DAEMON_k2l = "lad_tci6630"
-DAEMON_k2e = "lad_66ak2e"
-DAEMON_k2g = "lad_66ak2g"
-DAEMON_omapl138 = "lad_omapl138"
+DAEMON:omap5-evm = "lad_omap54xx_smp"
+DAEMON:dra7xx = "lad_dra7xx"
+DAEMON:k2hk = "lad_tci6638"
+DAEMON:k2l = "lad_tci6630"
+DAEMON:k2e = "lad_66ak2e"
+DAEMON:k2g = "lad_66ak2g"
+DAEMON:omapl138 = "lad_omapl138"
inherit autotools-brokensep pkgconfig update-rc.d systemd
INITSCRIPT_NAME = "tiipclad-daemon.sh"
INITSCRIPT_PARAMS = "defaults 10"
-SYSTEMD_SERVICE_${PN} = "tiipclad-daemon.service"
+SYSTEMD_SERVICE:${PN} = "tiipclad-daemon.service"
EXTRA_OECONF += "PLATFORM=${PLATFORM} KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${STAGING_KERNEL_BUILDDIR}"
@@ -39,7 +39,7 @@ do_configure() {
oe_runconf
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/init.d/
# Modify the startup scripts to point to the right
@@ -53,15 +53,15 @@ do_install_append() {
install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
}
-do_install_append_dra7xx() {
+do_install:append:dra7xx() {
install -d ${D}${sysconfdir}/modprobe.d/
install -c -m 644 ${WORKDIR}/omap_remoteproc.conf ${D}${sysconfdir}/modprobe.d/
}
PACKAGES =+ "${PN}-test"
-RDEPENDS_${PN}-test += "${PN}"
+RDEPENDS:${PN}-test += "${PN}"
-FILES_${PN}-test = " \
+FILES:${PN}-test = " \
${bindir}/NameServerApp \
${bindir}/MessageQApp \
${bindir}/MessageQMulti \
diff --git a/recipes-ti/ipc/ti-rpmsg-char.inc b/recipes-ti/ipc/ti-rpmsg-char.inc
index c404f926..df14d63f 100644
--- a/recipes-ti/ipc/ti-rpmsg-char.inc
+++ b/recipes-ti/ipc/ti-rpmsg-char.inc
@@ -15,4 +15,4 @@ PV = "0.3.0+git${SRCPV}"
S = "${WORKDIR}/git"
COMPATIBLE_HOST ?= "null"
-COMPATIBLE_HOST_ti-soc = "(.*)"
+COMPATIBLE_HOST:ti-soc = "(.*)"