aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/dmai/ti-dmai
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/dmai/ti-dmai')
-rw-r--r--recipes-ti/dmai/ti-dmai/arago-tdox210
-rw-r--r--recipes-ti/dmai/ti-dmai/doxygen_templates.tar.gzbin8012 -> 0 bytes
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh37
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm355_al.sh23
-rw-r--r--recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm365_al.sh25
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6446_al.sh19
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6467_al.sh19
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh42
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol137_al.sh19
-rwxr-xr-xrecipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol138_al.sh19
-rw-r--r--recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff64
-rw-r--r--recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff48
-rw-r--r--recipes-ti/dmai/ti-dmai/remove-unneeded-includes.patch26
-rw-r--r--recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh12
14 files changed, 0 insertions, 563 deletions
diff --git a/recipes-ti/dmai/ti-dmai/arago-tdox b/recipes-ti/dmai/ti-dmai/arago-tdox
deleted file mode 100644
index 81538cf3..00000000
--- a/recipes-ti/dmai/ti-dmai/arago-tdox
+++ /dev/null
@@ -1,210 +0,0 @@
-#!/bin/bash
-#
-#
-# This script sets a series of environment variable that are referenced
-# in a doxygen configuration file. The values passed in here are simply
-# plugged into the file locations and doxygen proceeds normaly.
-#
-# template location is ${VENDORS}/opensource/doxygen/templates/<version>
-#
-#
-
-# Revision history
-#! 02 Jul 2009 cring: Added cmd line args for doxygendir (-x) and template (-t)
-#! 13 Jul 2006 ada: New template smaller pdf generation
-#! 16 May 2006 ada: Added -p file to pdf for space in project names
-#! 08 May 2006 ada: Added pdf generation to tdox (Solaris/Linux only).
-#! 23 Jan 2006 ada: Overide file to change default doxyfile behaivior
-#! 19 Jan 2006 ada: 1093, ENUM_VALUES_PER_LINE set to 1, ref doxyfile via vers
-#! 05 Oct 2005 ada: 933, doxyfile in tools, removed win and unix vendors path
-#! 24 Aug 2005 ada: Added 897 changes, optional css c or jave optimization
-#! 18 Aug 2005 ada: inital version from AR 887
-
-# Set these defaults here as the usage statement uses them
-TDOX_TEMPLATEDIR=${TOOLS}/default/doxygen_templates
-DOXYGEN_EXECUTABLE=doxygen
-
-function usage
-{
- OPTIONS="`basename $0` code_location out_doc_location [-x doxygen_exe ] [-t tdox_templatedir] [-n project_name] [-v version] [-f FILE_PATTERNS ] [-s strip_dir] [-c css location] [-e exclude dirs] [-b enabled sections] [-m generate chm] [-p pdf_file] [-o override doxyfile] [-j]"
- echo "`basename $1` $OPTIONS"
- echo "Where: "
- echo "\tcode_location: Top of tree(s) to search for code (required as 1st param)"
- echo "\tout_doc_location: Output location for generated files (required as 2nd param)"
- echo "\t[-n project_name]: title of generated documentation (defaults to Project)"
- echo "\t[-x doxygen_exe]: location of doxygen executable (defaults to $DOXYGEN_EXECUTABLE)"
- echo "\t[-t tdox_templatedir]: location of tdox templates (defaults to $TDOX_TEMPLATEDIR)"
- echo "\t[-v version]: version number or string (defaults to 1.0)"
- echo "\t[-f FILE_PATTERNS]: Optional list of files to document (defaults to all)"
- echo "\t[-s strip_dirs]: Remove directory prefix from generated files (defaults to not remove)"
- echo "\t[-c path_to_css]: Path to a user suplied CSS style sheet"
- echo "\t[-e exclude dirs]: List of directories to exclude"
- echo "\t[-b enabled sections]: List of sections to enable"
- echo "\t[-m generate chm]: chm file name (required)"
- echo "\t[-p generate pdf <file>]: create <file>.pdf in html/pdf (Linux only)"
- echo "\t[-o override doxyfile]: file (advanced) Overide any doxyfile default"
- echo "\t[-j]: Optimize for Java (Generate class files) defaults to C"
- echo "\t[-r]: Call rshd to windows for chm generation (defaults to wine)"
- echo
- exit
-}
-
-function optimizeForJava
-{
- DOX_OPTIMIZE_OUTPUT_JAVA="YES"
- DOX_OPTIMIZE_OUTPUT_FOR_C="NO"
-}
-
-if [ "$#" -lt 2 ]; then
- echo "Invalid number of parameters"
- usage $0
-fi
-
-# get the required parameters then shift for the getopts parameters
-export DOX_INPUT="$1"
-shift
-export DOX_OUTPUT_DIRECTORY="$1"
-shift
-
-#set the global defaults
-DOX_QUIET="YES"
-DOX_OPTIMIZE_OUTPUT_JAVA="NO"
-DOX_OPTIMIZE_OUTPUT_FOR_C="YES"
-DOX_CHM_FILE=
-DOX_GENERATE_HTMLHELP="NO"
-OVERRIDE_FILE=""
-PDF=""
-
-# Process the rest of the arguments as getopts
-# parameters
-while getopts b:c:e:f:m:n:o:p:s:t:v:x:dhjr arg
-do
- case $arg in
- b) DOX_ENABLED_SECTIONS=${OPTARG};;
- c) DOX_HTML_STYLESHEET=${OPTARG};;
- d) DEBUG=1;;
- e) DOX_EXCLUDE=${OPTARG};;
- f) DOX_FILE_PATTERNS=${OPTARG};;
- h) usage;exit 0;;
- j) optimizeForJava;;
- r) USERSHD=1;;
- m) DOX_CHM_FILE=${OPTARG};DOX_GENERATE_HTMLHELP="YES";;
- n) DOX_PROJECT_NAME=${OPTARG};;
- s) DOX_STRIP_FROM_PATH=${OPTARG};;
- t) TDOX_TEMPLATEDIR=${OPTARG};;
- v) DOX_PROJECT_NUMBER=${OPTARG};;
- x) DOXYGEN_EXECUTABLE=${OPTARG};;
- o) OVERRIDE_FILE=${OPTARG};;
- p) PDF=${OPTARG};;
- \?) usage
- exit 2;;
- esac
-done
-
-if [ "$DEBUG" = "1" ]; then
- DOX_QUIET="NO"
- set -x
-fi
-
-if [ "$DOX_PROJECT_NAME" = "" ]; then
- DOX_PROJECT_NAME="Project"
-fi
-
-if [ "$DOX_PROJECT_NUMBER" = "" ]; then
- DOX_PROJECT_NUMBER="1.0"
-fi
-
-if [ "$DOX_FILE_PATTERNS" = "" ]; then
- DOX_FILE_PATTERNS="*.c \
- *.cc \
- *.cxx \
- *.cpp \
- *.c++ \
- *.d \
- *.java \
- *.ii \
- *.ixx \
- *.ipp \
- *.i++ \
- *.inl \
- *.h \
- *.hh \
- *.hxx \
- *.hpp \
- *.h++ \
- *.idl \
- *.odl \
- *.cs \
- *.php \
- *.php3 \
- *.inc \
- *.m \
- *.mm \
- *.dox"
-fi
-
-export DOX_INPUT
-export DOX_OUTPUT_DIRECTORY
-export DOX_PROJECT_NAME
-export DOX_PROJECT_NUMBER
-export DOX_FILE_PATTERNS
-export DOX_STRIP_FROM_PATH
-export DOX_QUIET
-export DOX_HTML_STYLESHEET
-export DOX_OPTIMIZE_OUTPUT_FOR_C
-export DOX_OPTIMIZE_OUTPUT_JAVA
-export DOX_EXCLUDE
-export DOX_ENABLED_SECTIONS
-export DOX_CHM_FILE
-export DOX_GENERATE_HTMLHELP
-export TDOX_TEMPLATEDIR
-
-
-# Make sure the dir exists
-mkdir -p $DOX_OUTPUT_DIRECTORY
-
-# Create temp file copy of doxyfile and append overrides to the end of the file
-cp ${TDOX_TEMPLATEDIR}/doxyfile /tmp/doxyfile$$
-
-chmod +w /tmp/doxyfile$$
-if [ "$OVERRIDE_FILE" != "" ]; then
- cat $OVERRIDE_FILE >> /tmp/doxyfile$$
-fi
-
-# Run doxygen and clean up temp file
-${DOXYGEN_EXECUTABLE} /tmp/doxyfile$$
-rm -f /tmp/doxyfile$$
-
-# Copy the TI banner gifs to the html directory.
-cp -p ${TDOX_TEMPLATEDIR}/*gif $DOX_OUTPUT_DIRECTORY/html
-
-# Generate PDF files
-if [ "$PDF" != "" ]; then
- if [ "$BUILD_HOST_OS" = "Linux" ]; then
- rm -rf $DOX_OUTPUT_DIRECTORY/html/pdf
- mkdir -p $DOX_OUTPUT_DIRECTORY/html/pdf
- cwd=`pwd`
- cd $DOX_OUTPUT_DIRECTORY/latex
- latex refman.tex
- makeindex refman.idx
- latex refman.tex
- latex_count=5
- while egrep -s 'Rerun (LaTeX|to get cross-references right)' refman.log && [ $$latex_count -gt 0 ]
- do
- latex refman.tex
- latex_count=`expr $$latex_count - 1`
- done
- dvips -o refman.ps refman.dvi
- ps2pdf refman.ps refman.pdf
- cd $cwd
- mv $DOX_OUTPUT_DIRECTORY/latex/refman.pdf $DOX_OUTPUT_DIRECTORY/html/pdf/${PDF}.pdf
- else
- echo "Sorry... pdf generation supported under Linux only"
- fi
-fi
-
-# Generate Windows compressed help
-if [ "$DOX_GENERATE_HTMLHELP" = "YES" ]; then
-
- echo "chm generation is not supported"
-fi
diff --git a/recipes-ti/dmai/ti-dmai/doxygen_templates.tar.gz b/recipes-ti/dmai/ti-dmai/doxygen_templates.tar.gz
deleted file mode 100644
index 6d613bf5..00000000
--- a/recipes-ti/dmai/ti-dmai/doxygen_templates.tar.gz
+++ /dev/null
Binary files differ
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh
deleted file mode 100755
index 2bfd03c2..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-apps.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Default Memory Map - for OMAP3530 dvsdk examples from 3.00.00.29 - this memory map is used for DMAI apps
-#
-# Start Addr Size Description
-# -------------------------------------------
-# 0x80000000 88 MB Linux
-# 0x85800000 08 MB CMEM
-# 0x86800000 16 MB DDRALGHEAP
-# 0x87800000 6 MB DDR2 (BIOS, Codecs, Applications)
-# 0x87E00000 1 MB DSPLINK (MEM)
-# 0x87F00000 4 KB DSPLINK (RESET)
-# 0x87F01000 1020 KB unused
-
-# sanity check to verify that we're using the right mem=xxM (88M in this case)
-awk '/MemTotal:/ {
- mem=$2
-
- if (mem > 88 * 1024)
- print "Warning! You need to use mem=88M or less on the kernel cmdline"
-
- printf "You have %dkB total memory for Linux\n", mem
-}' /proc/meminfo
-
-# Select cmemk parameters for best fit, i.e. starting at 0x85000000
-modprobe cmemk phys_start=0x85800000 phys_end=0x86800000 pools=20x4096,8x131072,5x1048576,1x1429440,1x256000,1x3600000,5x829440
-
-# insert DSP/BIOS Link driver
-#
-modprobe dsplinkk
-
-# make /dev/dsplink
-#rm -f /dev/dsplink
-#mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
-
-# insert Local Power Manager driver
-#
-modprobe lpm:omap3530
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm355_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm355_al.sh
deleted file mode 100755
index ca357e20..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm355_al.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-# 12MB
-modprobe cmemk phys_start=0x87400000 phys_end=0x88000000 pools=1x2903040,1x1529856,7x829440,1x524288,1x108680,1x81920,2x8192,6x4096
-
-./mapdmaq
-
-modprobe dm350mmap
-rm -f /dev/dm350mmap
-mknod /dev/dm350mmap c `awk "\\$2==\"dm350mmap\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm365_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm365_al.sh
deleted file mode 100644
index 36dc78ec..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm365_al.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# This loadmodules script is provided to support 1920x1080 resolution file based encode/decode DMAI unit test applications
-
-# Sample bootargs is given below
-# mem=60M console=ttyS0,115200n8 root=/dev/nfs rw nfsroot=<nfsroot> ip=dhcp video=davincifb:vid0=OFF:vid1=OFF:osd0=720x576x16,2025K dm365_imp.oper_mode=0
-
-depmod -a
-rmmod cmemk 2>/dev/null
-rmmod irqk 2>/dev/null
-rmmod edmak 2>/dev/null
-rmmod dm365mmap 2>/dev/null
-
-# Pools configuration
-modprobe cmemk phys_start=0x83C00000 phys_end=0x88000000 pools=1x384,2x5984,2x3133440,1x16384,1x48952,1x20480,1x60288,1x74,1x28,1x2048,1x6785280,1x146,1x896,1x65536,1x98,1x296,29x56,2x24,1x624,4x62,1x1456,1x18321120,1x65792,5x3523584,1x4194304,1x8355840
-
-#VC1 decode pool configuration
-# insmod cmemk.ko phys_start=0x83C00000 phys_end=0x88000000 pools=1x384,1x112665,3x7680,1x319264,2x1024,5x7208960,1x80,1x116,1x29184,1x2688,1x30720,1x551680,2x128,1x74,1x28,1x10240,1x47232,1x448,2x1152,1x8192,2x272896,18x56,2x24,1x86,4x62,2x7808,1x2097152
-
-modprobe irqk
-modprobe edmak
-modprobe dm365mmap
-
-rm -f /dev/dm365mmap
-mknod /dev/dm365mmap c `awk "\\$2==\"dm365mmap\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6446_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6446_al.sh
deleted file mode 100755
index b4a230d5..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6446_al.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-modprobe cmemk phys_start=0x87800000 phys_end=0x88E00000 pools=20x4096,8x202752,10x131072,2x1048576,1x2097152,10x829440,1x6750000
-modprobe dsplinkk ddr_start=0x8F800000 ddr_size=0x600000
-
-rm -rf /dev/dsplink
-mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6467_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6467_al.sh
deleted file mode 100755
index b4a230d5..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-dm6467_al.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-modprobe cmemk phys_start=0x87800000 phys_end=0x88E00000 pools=20x4096,8x202752,10x131072,2x1048576,1x2097152,10x829440,1x6750000
-modprobe dsplinkk ddr_start=0x8F800000 ddr_size=0x600000
-
-rm -rf /dev/dsplink
-mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh
deleted file mode 100755
index 094d23d1..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-o3530_al.sh
+++ /dev/null
@@ -1,42 +0,0 @@
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-#
-# Default Memory Map
-#
-# Start Addr Size Description
-# -------------------------------------------
-# 0x80000000 88 MB Linux
-# 0x85800000 08 MB CMEM
-# 0x86800000 24 MB DDRALGHEAP
-# 0x87800000 6 MB DDR2 (BIOS, Codecs, Applications)
-# 0x87E00000 1 MB DSPLINK (MEM)
-# 0x87F00000 4 KB DSPLINK (RESET)
-# 0x87F01000 1020 KB unused
-
-modprobe cmemk phys_start=0x85800000 phys_end=0x86800000 pools=20x4096,8x131072,4x829440,1x5250000,1x1429440,1x256000
-
-
-# insert DSP/BIOS Link driver
-#
-modprobe dsplinkk
-
-# make /dev/dsplink
-rm -f /dev/dsplink
-mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
-
-
-# insert Local Power Manager driver
-#
-modprobe lpm:omap3530
-
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol137_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol137_al.sh
deleted file mode 100755
index 2c98c787..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol137_al.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-modprobe cmemk phys_start=0xC2200000 phys_end=0xC3200000 pools=1x5250000,3x1048576,3x829440,1x256000,4x131072
-modprobe dsplinkk
-
-rm -rf /dev/dsplink
-mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol138_al.sh b/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol138_al.sh
deleted file mode 100755
index 2c98c787..00000000
--- a/recipes-ti/dmai/ti-dmai/loadmodules-ti-dmai-ol138_al.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# loadmodules.sh
-#
-# Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation version 2.1 of the License.
-#
-# This program is distributed #as is# WITHOUT ANY WARRANTY of any kind,
-# whether express or implied; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-
-modprobe cmemk phys_start=0xC2200000 phys_end=0xC3200000 pools=1x5250000,3x1048576,3x829440,1x256000,4x131072
-modprobe dsplinkk
-
-rm -rf /dev/dsplink
-mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
diff --git a/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff b/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff
deleted file mode 100644
index 63f9cc68..00000000
--- a/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff
+++ /dev/null
@@ -1,64 +0,0 @@
-From 06c4cfeec98f4f1e31543878ceb74c5fff1907e4 Mon Sep 17 00:00:00 2001
-From: Enrico Butera <ebutera@users.berlios.de>
-Date: Thu, 22 Dec 2011 11:01:58 +0100
-Subject: [PATCH 1/2] adjust videdev headers for recent kernels
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- .../packages/ti/sdo/dmai/linux/omap3530/Capture.c | 1 -
- .../ti/sdo/dmai/linux/omap3530/Display_v4l2.c | 1 -
- .../ti/sdo/dmai/linux/omap3530/_VideoBuf.c | 1 -
- .../ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h | 1 -
- 4 files changed, 0 insertions(+), 4 deletions(-)
-
-diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
-index a924169..c2b45d2 100644
---- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
-+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
-@@ -40,7 +40,6 @@
- #include <sys/mman.h>
- #include <sys/ioctl.h>
- #include <asm/types.h>
--#include <linux/videodev.h>
- #include <linux/videodev2.h>
-
- #include <xdc/std.h>
-diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
-index 0d01b39..0c35efe 100644
---- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
-+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
-@@ -38,7 +38,6 @@
- #include <sys/ioctl.h>
- #include <sys/mman.h>
- #include <errno.h>
--#include <linux/videodev.h>
- #include <linux/videodev2.h>
-
- #include <xdc/std.h>
-diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
-index 5615e2f..5cb712d 100644
---- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
-+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
-@@ -38,7 +38,6 @@
- #include <sys/ioctl.h>
- #include <sys/mman.h>
- #include <errno.h>
--#include <linux/videodev.h>
- #include <linux/videodev2.h>
-
- #include <xdc/std.h>
-diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
-index b2128a3..dbaa4eb 100644
---- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
-+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
-@@ -34,7 +34,6 @@
- #ifndef ti_sdo_dai_linux_priv__VideoBuf_h_
- #define ti_sdo_dai_linux_priv__VideoBuf_h_
-
--#include <linux/videodev.h>
- #include <linux/videodev2.h>
-
- #include <ti/sdo/dmai/BufferGfx.h>
---
-1.7.2.5
-
diff --git a/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff b/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff
deleted file mode 100644
index 2f328c0e..00000000
--- a/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff
+++ /dev/null
@@ -1,48 +0,0 @@
-From 86e89bb160cfe67c173f1260b93066b12dd73580 Mon Sep 17 00:00:00 2001
-From: Enrico Butera <ebutera@users.berlios.de>
-Date: Thu, 22 Dec 2011 11:03:58 +0100
-Subject: [PATCH 2/2] fix toolchain names in config.bld
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- .../dmai/packages/config.bld | 24 +------------------
- 1 files changed, 2 insertions(+), 22 deletions(-)
-
-diff --git a/davinci_multimedia_application_interface/dmai/packages/config.bld b/davinci_multimedia_application_interface/dmai/packages/config.bld
-index 8c2e96e..566f907 100644
---- a/davinci_multimedia_application_interface/dmai/packages/config.bld
-+++ b/davinci_multimedia_application_interface/dmai/packages/config.bld
-@@ -44,28 +44,8 @@ var C6X = xdc.useModule('ti.targets.C64P');
- C6X.rootDir = codegen;
- C6X.platform = xdcplat;
-
--/* User passes in $(CROSS_COMPILE) where $(CROSS_COMPILE)gcc is their compiler
-- Then the TOOLDIR and LONGNAME are derived based on a regex of CROSS_COMPILE
--*/
--var crosscompile = "" + java.lang.System.getenv("CROSS_COMPILE");
--
--var tooldir = "";
--var longName = "";
--
--/* Search CROSS_COMPILE for bin/ If only 1 bin/ is found, set the tooldir to
-- the path prior to bin/ and the prefix to "bin/" + remainder of path,
-- else leave the tooldir as "" and set the LONGNAME to the full CROSS_COMPILE
-- path
--*/
--var regex = new RegExp("bin/");
--var find = crosscompile.split( regex );
--
--if (find[0]!=crosscompile && find.length==2) {
-- tooldir = find[0];
-- longName = "bin/" + find[1] + "gcc";
--} else {
-- longName = crosscompile + "gcc";
--}
-+var tooldir = "" + java.lang.System.getenv("CSTOOL_DIR");
-+var longName = "" + java.lang.System.getenv("MVTOOL_PREFIX") + "gcc";
-
- /* location of the GCC Arm9 tools */
- var GCArmv5T = xdc.useModule('gnu.targets.arm.GCArmv5T');
---
-1.7.2.5
-
diff --git a/recipes-ti/dmai/ti-dmai/remove-unneeded-includes.patch b/recipes-ti/dmai/ti-dmai/remove-unneeded-includes.patch
deleted file mode 100644
index cfd325a3..00000000
--- a/recipes-ti/dmai/ti-dmai/remove-unneeded-includes.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: a/packages/ti/sdo/dmai/Makefile
-===================================================================
---- a/packages/ti/sdo/dmai/Makefile
-+++ b/packages/ti/sdo/dmai/Makefile
-@@ -107,7 +107,7 @@ XDCPATH += $(XDC_INSTALL_DIR)/packages;$
-
- CPP_FLAGS += -I$(XDC_INSTALL_DIR)/packages -I$(DMAI_INSTALL_DIR)/packages -I$(CE_INSTALL_DIR)/packages -I$(FC_INSTALL_DIR)/packages -I$(XDAIS_INSTALL_DIR)/packages -I$(CODEC_INSTALL_DIR)/packages -DDmai_Device_$(PLATFORM_DEVICE)
-
--GCC_CPP_FLAGS += $(CPP_FLAGS) -I$(LINUXKERNEL_INSTALL_DIR)/include -I$(LINUXKERNEL_INSTALL_DIR)/arch/arm/include -I$(LINUXKERNEL_INSTALL_DIR)/arch/arm/$(PLATFORM_ARCH)/include $(HAVE_AUTOCONFIG) -I$(CMEM_INSTALL_DIR)/packages -I$(LINK_INSTALL_DIR) -DDmai_BuildOs_linux -Dxdc_target_types__=gnu/targets/std.h -I$(LINUXLIBS_INSTALL_DIR)/include -Dxdc_target_name__=arm/GCArmv5T
-+GCC_CPP_FLAGS += $(CPP_FLAGS) $(HAVE_AUTOCONFIG) -I$(CMEM_INSTALL_DIR)/packages -I$(LINK_INSTALL_DIR) -DDmai_BuildOs_linux -Dxdc_target_types__=gnu/targets/std.h -I$(LINUXLIBS_INSTALL_DIR)/include -Dxdc_target_name__=arm/GCArmv5T
- C64P_CPP_FLAGS += $(CPP_FLAGS) -I$(BIOS_INSTALL_DIR)/packages/ti/bios/include -I$(BIOS_INSTALL_DIR)/packages -DDmai_BuildOs_bios -Dxdc_target__='<ti/targets/std.h>' -I$(CODEGEN_INSTALL_DIR)/include -mv6400+ -pdse225 -eo$(PLATFORM_DEVICE).o$(EXT)
-
- GCC_C_FLAGS += $(C_FLAGS) -Wall
-Index: a/packages/ti/sdo/dmai/apps/Makefile.app
-===================================================================
---- a/packages/ti/sdo/dmai/apps/Makefile.app
-+++ b/packages/ti/sdo/dmai/apps/Makefile.app
-@@ -121,7 +121,7 @@ C64P_C_FLAGS = $(C_FLAGS)
- GCC_CPP_FLAGS = $(CPP_FLAGS) -I$(LINUXKERNEL_INSTALL_DIR)/include
- C64P_CPP_FLAGS = $(CPP_FLAGS) -pdse225 -I$(CODEGEN_INSTALL_DIR)/include -mv6400+ -I$(BIOS_INSTALL_DIR)/packages/ti/bios/include -eo$(PLATFORM_DEVICE).o$(EXT)
-
--GCC_LD_FLAGS = $(LD_FLAGS) -lpthread -lm -L$(LINUXLIBS_INSTALL_DIR)/lib -lasound
-+GCC_LD_FLAGS = $(LD_FLAGS) -lpthread -lm --sysroot=$(PKG_CONFIG_SYSROOT_DIR) -L$(LINUXLIBS_INSTALL_DIR)/lib -lasound
- C64P_LD_FLAGS = $(LD_FLAGS) -z -w -x -c -i$(RTDX_INSTALL_DIR)/packages/ti/rtdx/iom/lib/debug -i$(RTDX_INSTALL_DIR)/packages/ti/rtdx/cio/lib/release -i$(RTDX_INSTALL_DIR)/packages/ti/rtdx/lib/c6000
-
- SOURCES = $(wildcard *.c)
diff --git a/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh b/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh
deleted file mode 100644
index 81d00af8..00000000
--- a/recipes-ti/dmai/ti-dmai/unloadmodules-ti-dmai-apps.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-# Unload modules - DMAI - OMAP3530
-
-# remove lpm module
-rmmod lpm:omap3530
-
-# remove DSP/BIOS Link driver
-rmmod dsplinkk
-#rm -f /dev/dsplink
-
-# remove cmem module
-rmmod cmemk
-