aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch')
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch b/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
deleted file mode 100644
index 8b7aa25a..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 607192f42d65e17f55fc6e85c00019bf71b18770 Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 19:47:32 +0200
-Subject: [PATCH 1/1] selftests: breakpoints: allow to cross-compile for
- aarch64/arm64
-
-To build breakpoint_test_arm64, ARCH value is only tested for "aarch64".
-It covers only the native build because it's computed from uname -m output.
-For cross-compilation, ARCH is set to arm64 and prevent to cross-compile
-the test.
-Fix the test to allow both native and cross-compilation of the test.
-
-Note: glibc is missing several of the TRAP_* constants in the userspace
- definitions. Specifically TRAP_BRANCH and TRAP_HWBKPT.
- See https://sourceware.org/bugzilla/show_bug.cgi?id=21286
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
----
- tools/testing/selftests/breakpoints/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/tools/testing/selftests/breakpoints/Makefile
-+++ b/tools/testing/selftests/breakpoints/Makefile
-@@ -5,7 +5,7 @@ ARCH ?= $(shell echo $(uname_M) | sed -e
- ifeq ($(ARCH),x86)
- TEST_PROGS := breakpoint_test
- endif
--ifeq ($(ARCH),aarch64)
-+ifneq (,$(filter $(ARCH),aarch64 arm64))
- TEST_PROGS := breakpoint_test_arm64
- endif
-