aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch28
-rw-r--r--recipes-graphics/gbm/libgbm_10.0.0.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch b/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch
new file mode 100644
index 00000000..31134ab6
--- /dev/null
+++ b/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch
@@ -0,0 +1,28 @@
+From ea5fc8da36886490d0ee40d475733cd98e38c2ec Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Tue, 28 Aug 2018 18:35:55 -0400
+Subject: [PATCH] gbm.c: include <sys/sysmacros.h> for minor/major in new glibc
+
+glibc 2.28+ now requires this.
+https://sourceware.org/bugzilla/show_bug.cgi?id=19239
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ gbm.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/gbm.c b/gbm.c
+index c046b1a..9356d7b 100644
+--- a/gbm.c
++++ b/gbm.c
+@@ -35,6 +35,7 @@
+ #include <stdint.h>
+
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <errno.h>
+--
+2.7.4
+
diff --git a/recipes-graphics/gbm/libgbm_10.0.0.bb b/recipes-graphics/gbm/libgbm_10.0.0.bb
index 848a5f66..38715ccf 100644
--- a/recipes-graphics/gbm/libgbm_10.0.0.bb
+++ b/recipes-graphics/gbm/libgbm_10.0.0.bb
@@ -12,6 +12,7 @@ BRANCH = "next"
SRCREV = "96f37555c7e82a417b02051661377b10e6b3966e"
-SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH}"
+SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH} \
+ file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch"
S = "${WORKDIR}/git"