aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/framework-components
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/framework-components')
-rw-r--r--meta-ti-extras/recipes-ti/framework-components/ti-framework-components.inc21
-rw-r--r--meta-ti-extras/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb9
-rw-r--r--meta-ti-extras/recipes-ti/framework-components/ti-framework-components_3.40.02.07.bb9
3 files changed, 39 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/framework-components/ti-framework-components.inc b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components.inc
new file mode 100644
index 00000000..81407ed7
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "TI Framework Components"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+
+require recipes-ti/includes/ti-paths.inc
+
+S = "${WORKDIR}/framework_components_${PV}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball"
+
+do_install() {
+ CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
+ install -d ${D}${FC_INSTALL_DIR_RECIPE}
+ cp ${CP_ARGS} ${S}/* ${D}${FC_INSTALL_DIR_RECIPE}
+}
+
+INSANE_SKIP:${PN} = "ldflags"
+
+ALLOW_EMPTY:${PN} = "1"
+FILES:${PN}-dev += "${FC_INSTALL_DIR_RECIPE}"
diff --git a/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb
new file mode 100644
index 00000000..1ec10b15
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_2.26.00.01.bb
@@ -0,0 +1,9 @@
+require ti-framework-components.inc
+
+PV = "2_26_00_01"
+PR = "r2"
+
+LIC_FILES_CHKSUM = "file://framework_components_2_26_00_01_manifest.html;md5=3250f9da7ee72284c07f8dd840400c75"
+
+SRC_URI[fctarball.md5sum] = "40b51cade2f9ae6e6f6dca73c17065af"
+SRC_URI[fctarball.sha256sum] = "3f7a12a51dfe87310828a31518d7ef8f9039e59269c0ca24f74a68433c235048"
diff --git a/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_3.40.02.07.bb b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_3.40.02.07.bb
new file mode 100644
index 00000000..56c00283
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/framework-components/ti-framework-components_3.40.02.07.bb
@@ -0,0 +1,9 @@
+require ti-framework-components.inc
+
+PV = "3_40_02_07"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://framework_components_${PV}_Manifest.html;md5=0dd131dd53300f517b14dba8824f8b0a"
+
+SRC_URI[fctarball.md5sum] = "36dd2312ea8d70aa2ae0a05a24dbf54e"
+SRC_URI[fctarball.sha256sum] = "69082a0f86d12c24b39a1293ec35cf8007b850479898d5ae485ec1e8cf2e8c72"