aboutsummaryrefslogtreecommitdiffstats
path: root/extras/recipes-ti/c6accel/ti-c6accel
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-ti/c6accel/ti-c6accel')
-rw-r--r--extras/recipes-ti/c6accel/ti-c6accel/0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch82
-rw-r--r--extras/recipes-ti/c6accel/ti-c6accel/fix-loadmodule.patch81
2 files changed, 163 insertions, 0 deletions
diff --git a/extras/recipes-ti/c6accel/ti-c6accel/0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch b/extras/recipes-ti/c6accel/ti-c6accel/0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch
new file mode 100644
index 00000000..a108c6e0
--- /dev/null
+++ b/extras/recipes-ti/c6accel/ti-c6accel/0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch
@@ -0,0 +1,82 @@
+From 192b19046a67263da44203bf50a5b51d0a655fec Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 31 Dec 2010 15:26:37 +0100
+Subject: [PATCH] soc: honour buildsystem CFLAGS and LDFLAGS when set
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ soc/app/Makefile | 13 ++++---------
+ soc/c6accelw/Makefile | 14 ++++----------
+ 2 files changed, 8 insertions(+), 19 deletions(-)
+
+diff --git a/soc/app/Makefile b/soc/app/Makefile
+index 2647746..bed937e 100755
+--- a/soc/app/Makefile
++++ b/soc/app/Makefile
+@@ -53,15 +53,10 @@ CONFIGURO = $(XDC_INSTALL_DIR)/xs xdc.tools.configuro
+ CONFIG_BLD = ../../config.bld
+
+ ifeq ($(BUILD_TYPE), release)
+-ifeq ($(ARM_ISA),armv7-a)
+- C_FLAGS += -O3 -march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -mfloat-abi=softfp
+-endif
+-ifeq ($(ARM_ISA),armv5t)
+- C_FLAGS += -mlittle-endian -march=armv5t -mtune=arm9tdmi -mabi=aapcs-linux -O
+-endif
++C_FLAGS += $(CFLAGS)
+ else
+ CPP_FLAGS += -DNDEBUG
+- C_FLAGS += -Wall -g
++ C_FLAGS += $(CFLAGS) -Wall -g
+ endif
+
+
+@@ -72,7 +67,7 @@ ifeq ($(PLATFORM),omapl138)
+ C_FLAGS += -DPLATFORM=138
+ endif
+
+-LD_FLAGS += -L$(LINUXLIBS_INSTALL_DIR)/lib -lm -lpthread
++LD_FLAGS += $(LDFLAGS) -L$(LINUXLIBS_INSTALL_DIR)/lib -lm -lpthread
+ C6ACCEL_LIB += ../c6accelw/lib/c6accelw_$(PLATFORM).a470MV
+
+ COMPILE.c = $(VERBOSE) $(CSTOOL_PREFIX)gcc $(CPP_FLAGS) $(C_FLAGS) $(CPP_FLAGS) -c
+@@ -102,7 +97,7 @@ $(TARGET): $(OBJFILES) $(C6ACCEL_LIB) $(XDC_LFILE)
+
+ $(OBJFILES): %.o: %.c $(HEADERS) $(XDC_CFLAGS)
+ @echo Compiling $@ from $<..
+- $(COMPILE.c) $(shell cat $(XDC_CFLAGS)) -o $@ $<
++ $(COMPILE.c) $(shell cat $(XDC_CFLAGS) | sed 's:-march=armv5t::g') -o $@ $<
+
+ $(XDC_LFILE) $(XDC_CFLAGS): $(XDC_CFGFILE)
+ @echo
+diff --git a/soc/c6accelw/Makefile b/soc/c6accelw/Makefile
+index cc58acf..298ab3b 100755
+--- a/soc/c6accelw/Makefile
++++ b/soc/c6accelw/Makefile
+@@ -21,19 +21,13 @@ BUILD_TYPE=release
+ CPP_FLAGS += -I../packages -I$(XDC_INSTALL_DIR)/packages -I$(CE_INSTALL_DIR)/packages -I$(XDAIS_INSTALL_DIR)/packages -Dxdc_target_name__=arm/GCArmv5T -Dxdc_target_types__=gnu/targets/std.h
+
+ ifeq ($(BUILD_TYPE), release)
+-ifeq ($(ARM_ISA),armv7-a)
+- C_FLAGS += -O3 -march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -mfloat-abi=softfp
+- endif
+-ifeq ($(ARM_ISA),armv5t)
+- C_FLAGS += -mlittle-endian -march=armv5t -mtune=arm9tdmi -mabi=aapcs-linux -O
+- endif
+-
++C_FLAGS += $(CFLAGS)
+ else
+- CPP_FLAGS += -DNDEBUG
+- C_FLAGS += -Wall -g
++ CPP_FLAGS += -DNDEBUG
++ C_FLAGS += $(CFLAGS) -Wall -g
+ endif
+
+-LD_FLAGS += -L$(LINUXLIBS_INSTALL_DIR)/lib
++LD_FLAGS += $(LDFLAGS) -L$(LINUXLIBS_INSTALL_DIR)/lib
+ AR_FLAGS +=
+
+ COMPILE.c = $(VERBOSE) $(CSTOOL_PREFIX)gcc $(CPP_FLAGS) $(C_FLAGS) -c
+--
+1.6.6.1
+
diff --git a/extras/recipes-ti/c6accel/ti-c6accel/fix-loadmodule.patch b/extras/recipes-ti/c6accel/ti-c6accel/fix-loadmodule.patch
new file mode 100644
index 00000000..9921f29e
--- /dev/null
+++ b/extras/recipes-ti/c6accel/ti-c6accel/fix-loadmodule.patch
@@ -0,0 +1,81 @@
+diff -uNr c6accel_1_00_00_04_orig/soc/app/omap3530/loadmodules_omap3530_c6accel.sh c6accel_1_00_00_04/soc/app/omap3530/loadmodules_omap3530_c6accel.sh
+--- c6accel_1_00_00_04_orig/soc/app/omap3530/loadmodules_omap3530_c6accel.sh 2010-07-26 16:18:35.000000000 -0500
++++ c6accel_1_00_00_04/soc/app/omap3530/loadmodules_omap3530_c6accel.sh 2010-09-12 11:50:46.129159981 -0500
+@@ -1,4 +1,4 @@
+-# loadmodules.sh
++#!/bin/sh
+ #
+ # Copyright (C) $year Texas Instruments Incorporated - http://www.ti.com/
+ #
+@@ -11,34 +11,16 @@
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ # Lesser General Public License for more details.
+
+-#
+-# Default Memory Map
+-#
+-# Start Addr Size Description
+-# -------------------------------------------
+-# 0x80000000 88 MB Linux
+-# 0x85800000 08 MB CMEM
+-# 0x86800000 24 MB DDRALGHEAP
+-# 0x87800000 6 MB DDR2 (BIOS, Codecs, Applications)
+-# 0x87E00000 1 MB DSPLINK (MEM)
+-# 0x87F00000 4 KB DSPLINK (RESET)
+-# 0x87F01000 1020 KB unused
+-rmmod cmemk.ko
+-rmmod lpm_omap3530.ko
+-rmmod dsplinkk
+-# Allocate 15MB for CMEM
+-insmod cmemk.ko phys_start=0x86300000 phys_end=0x87200000 pools=20x4096
++# remove previously loaded cmem to ensure that it configured to use our pool configuration
++rmmod cmemk 2>/dev/null
+
+-# insert DSP/BIOS Link driver
+-#
+-insmod dsplinkk.ko
++# Allocate 15MB for CMEM
++modprobe cmemk phys_start=0x86300000 phys_end=0x87200000 pools=20x4096 allowOverlap=1
++modprobe dsplinkk
++modprobe lpm_omap3530
+
+ # make /dev/dsplink
+ rm -rf /dev/dsplink
+ mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
+
+
+-# insert Local Power Manager driver
+-#
+-insmod lpm_omap3530.ko
+-
+diff -uNr c6accel_1_00_00_04_orig/soc/app/omapl138/loadmodules_omapl138_c6accel.sh c6accel_1_00_00_04/soc/app/omapl138/loadmodules_omapl138_c6accel.sh
+--- c6accel_1_00_00_04_orig/soc/app/omapl138/loadmodules_omapl138_c6accel.sh 2010-07-27 09:45:37.000000000 -0500
++++ c6accel_1_00_00_04/soc/app/omapl138/loadmodules_omapl138_c6accel.sh 2010-09-12 11:52:07.193160179 -0500
+@@ -1,4 +1,4 @@
+-#
++#!/bin/sh
+ # Copyright (c) 2008, Texas Instruments Incorporated
+ # All rights reserved.
+ #
+@@ -29,15 +29,14 @@
+ # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+ # EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ #
+-rmmod dsplinkk.ko
+-rmmod cmemk.ko
++
++# remove previously loaded cmem to ensure that its configured to use our pool configuration.
++rmmod cmemk 2>/dev/null
++
+ # insert cmemk, tell it to occupy physical 120MB-128MB, create
+ # 20 4K buffers, 10 128K buffers and two 1MB buffers
+-insmod cmemk.ko phys_start=0xC2000000 phys_end=0xC4000000 pools=20x4096
+-
+-# insert DSP/BIOS Link driver
+-#
+-insmod dsplinkk.ko
++modprobe cmemk phys_start=0xC2000000 phys_end=0xC4000000 pools=20x4096 allowOverlap=1
++modprobe dsplinkk
+
+ # make /dev/dsplink
+ rm -f /dev/dsplink