aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb2
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb6
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb6
-rw-r--r--recipes-kernel/linux/cmem.inc16
-rw-r--r--recipes-ti/devtools/ti-cgt6x_8.2.2.bb8
-rw-r--r--recipes-ti/includes/ti-unpack.inc12
7 files changed, 26 insertions, 26 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 540a665c..7ad6205d 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -67,7 +67,7 @@ PARALLEL_XDC = "--jobs=${BB_NUMBER_THREADS}"
PARALLEL_MAKE = ""
def get_doxygen_support(d):
- if d.getVar('TI_PDK_DOXYGEN_SUPPORT', True) == '1':
+ if d.getVar('TI_PDK_DOXYGEN_SUPPORT') == '1':
return ''
return 'DOXYGEN_SUPPORT=no'
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index 761210e7..22a8c4f8 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -1,5 +1,5 @@
python __anonymous() {
- features = d.getVar("MACHINE_FEATURES", d, 1)
+ features = d.getVar("MACHINE_FEATURES")
if not features:
return
if "mmip" not in features:
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index 52df495d..dafaac1e 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -14,11 +14,11 @@ SRCREV = "c0afab259de59909cfe74c01f3f7fbaa147f94b5"
# There's only hardfp version available
python __anonymous() {
- tunes = d.getVar("TUNE_FEATURES", d, 1)
+ tunes = d.getVar("TUNE_FEATURES")
if not tunes:
return
- pkgn = d.getVar("PN", d, 1)
- pkgv = d.getVar("PV", d, 1)
+ pkgn = d.getVar("PN")
+ pkgv = d.getVar("PV")
if "callconvention-hard" not in tunes:
bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 282a4ab2..d17411ec 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -12,11 +12,11 @@ SRCREV = "358fe42d34a7570896e5d1639869da564ddd0484"
# There's only hardfp version available
python __anonymous() {
- tunes = d.getVar("TUNE_FEATURES", d, 1)
+ tunes = d.getVar("TUNE_FEATURES")
if not tunes:
return
- pkgn = d.getVar("PN", d, 1)
- pkgv = d.getVar("PV", d, 1)
+ pkgn = d.getVar("PN")
+ pkgv = d.getVar("PV")
if "callconvention-hard" not in tunes:
bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-kernel/linux/cmem.inc b/recipes-kernel/linux/cmem.inc
index ad122799..8325c00f 100644
--- a/recipes-kernel/linux/cmem.inc
+++ b/recipes-kernel/linux/cmem.inc
@@ -39,13 +39,13 @@ python do_unpack() {
# Initialize with empty string to simplify logic to append to SRC_URI
cmem_dtsi = set([''])
- for cmem_machine in (d.getVar('CMEM_MACHINE', True) or '').split():
+ for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
# Create copy of data for additional override
localdata = bb.data.createCopy(d)
localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
bb.data.update_data(localdata)
- cmem_dtsi.add(localdata.getVar('CMEM_DTSI', True))
+ cmem_dtsi.add(localdata.getVar('CMEM_DTSI'))
d.appendVar('SRC_URI', ' file://'.join(cmem_dtsi))
bb.build.exec_func('base_do_unpack', d)
@@ -56,27 +56,27 @@ python do_setup_cmem() {
old_overrides = d.getVar('OVERRIDES', False)
- if d.getVar('RESERVE_CMEM', True) is '1':
- for cmem_machine in (d.getVar('CMEM_MACHINE', True) or '').split():
+ if d.getVar('RESERVE_CMEM') is '1':
+ for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
# Create copy of data for additional override
localdata = bb.data.createCopy(d)
localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
bb.data.update_data(localdata)
# Get source directory and dtsi filename
- src_dir = localdata.getVar('WORKDIR', True)
- src_dtsi = localdata.getVar('CMEM_DTSI', True)
+ src_dir = localdata.getVar('WORKDIR')
+ src_dtsi = localdata.getVar('CMEM_DTSI')
# Get destination directory and destination dtsi filename which adds
# the MACHINE prefix.
- dst_dir = os.path.join(localdata.getVar('S', True), 'arch/arm/boot/dts')
+ dst_dir = os.path.join(localdata.getVar('S'), 'arch/arm/boot/dts')
dst_dtsi = localdata.expand('${MACHINE}-${CMEM_DTSI}')
# Copy cmem.dtsi into source tree
shutil.copy(os.path.join(src_dir,src_dtsi), os.path.join(dst_dir,dst_dtsi))
# Inject dtsi into each dts in list
- for dtb in (localdata.getVar('CMEM_DEVICETREE', True) or '').split():
+ for dtb in (localdata.getVar('CMEM_DEVICETREE') or '').split():
dts = dtb[:-4] + '.dts'
with open(os.path.join(dst_dir,dts), 'a') as dts_file:
diff --git a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
index 04e55ae9..53f52526 100644
--- a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
+++ b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
@@ -13,14 +13,14 @@ COMPATIBLE_HOST_class-target = "arm.*-linux"
# For now we only have hardfp version for target class
python __anonymous() {
- c = d.getVar("CLASSOVERRIDE", d, 1)
+ c = d.getVar("CLASSOVERRIDE")
if c == "class-target":
- tunes = d.getVar("TUNE_FEATURES", d, 1)
+ tunes = d.getVar("TUNE_FEATURES")
if not tunes:
return
- pkgn = d.getVar("PN", d, 1)
- pkgv = d.getVar("PV", d, 1)
+ pkgn = d.getVar("PN")
+ pkgv = d.getVar("PV")
if "callconvention-hard" not in tunes:
bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-ti/includes/ti-unpack.inc b/recipes-ti/includes/ti-unpack.inc
index cc315dff..a571fd5d 100644
--- a/recipes-ti/includes/ti-unpack.inc
+++ b/recipes-ti/includes/ti-unpack.inc
@@ -29,21 +29,21 @@ python ti_bin_do_unpack() {
localdata = bb.data.createCopy(d)
bb.data.update_data(localdata)
- binfile = d.getVar('BINFILE', localdata)
+ binfile = localdata.getVar('BINFILE')
binfile = bb.data.expand(binfile, localdata)
# Change to the working directory
save_cwd = os.getcwd()
- workdir = d.getVar('WORKDIR', localdata)
+ workdir = localdata.getVar('WORKDIR')
workdir = bb.data.expand(workdir, localdata)
os.chdir(workdir)
# Get unpack args
- arg_string = d.getVar('TI_BIN_UNPK_ARGS', localdata)
+ arg_string = localdata.getVar('TI_BIN_UNPK_ARGS')
arg_string = bb.data.expand(arg_string, localdata)
# Get unpack commands
- cmd_string = d.getVar('TI_BIN_UNPK_CMDS', localdata)
+ cmd_string = localdata.getVar('TI_BIN_UNPK_CMDS')
cmd_list = cmd_string.split( ":" )
# Make the InstallJammer binary executable so we can run it
@@ -61,14 +61,14 @@ python ti_bin_do_unpack() {
f = os.popen(filename,'w')
for cmd in cmd_list:
if cmd == "workdir":
- wdext = d.getVar('TI_BIN_UNPK_WDEXT', localdata)
+ wdext = localdata.getVar('TI_BIN_UNPK_WDEXT')
wdext = bb.data.expand(wdext, localdata)
cmd = workdir+wdext
f.write(cmd+'\n');
f.close()
# Expand the tarball that was created if required
- tarfile = d.getVar('TARFILE', localdata)
+ tarfile = localdata.getVar('TARFILE')
if bool(tarfile) == True:
tarfile = bb.data.expand(tarfile, localdata)
tcmd = 'tar x --no-same-owner -f %s -C %s' % (tarfile, workdir)