aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb7
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr.inc4
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch27
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch28
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb2
5 files changed, 2 insertions, 66 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
index aab8ae6c..7c3f9e1b 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -1,14 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/multiprocmgr:"
-
SUMMARY = "TI Multiproc Manager test code"
include multiprocmgr.inc
-SRC_URI += " \
- file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
- file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
-"
-
PR = "${INC_PR}.2"
DEPENDS = "multiprocmgr cmem"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc
index 40a20af9..64fb6f6f 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr.inc
+++ b/recipes-ti/multiprocmgr/multiprocmgr.inc
@@ -9,10 +9,10 @@ MULTIPROCMGR_GIT_PROTOCOL = "git"
MULTIPROCMGR_GIT_BRANCH = "master"
# The following commits correspond to DEV.MPM-3.00.05.00
-MULTIPROCMGR_SRCREV = "f7fb3b7c21b3f6dd8b4adeef5df5be1824b9be73"
+MULTIPROCMGR_SRCREV = "810d8a31c797d07abe808cb3fa89465fa934d4dd"
PV = "3.0.5.0"
-INC_PR = "r0"
+INC_PR = "r1"
BRANCH = "${MULTIPROCMGR_GIT_BRANCH}"
SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
deleted file mode 100644
index 25deedcc..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 17c307ff6e67af43f243366baa2ccc01f89cdddd Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Mon, 23 Apr 2018 15:35:44 -0400
-Subject: [PATCH] mpmdlif.c: don't hardcode kernel's "uapi" location
- keystone_remoteproc.h
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- src/daemon/mpmdlif.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
-index 0c31604..d287bbc 100644
---- a/src/daemon/mpmdlif.c
-+++ b/src/daemon/mpmdlif.c
-@@ -47,7 +47,7 @@
- #include <stdint.h>
-
- #define _LINUX_TYPES_H
--#include "uapi/linux/keystone_remoteproc.h"
-+#include "linux/keystone_remoteproc.h"
- #include "internal/rsc_types.h"
- //#include <elf.h>
- // #define LOADER_DEBUG
---
-2.7.4
-
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
deleted file mode 100644
index c3315cfc..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 95921ccf77ae037bb3b95f45a632f60975c6c9bb Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Tue, 11 Feb 2020 17:03:18 -0500
-Subject: [PATCH] mpmdlif.c: don't suppress kernel <linux/types.h> inclusion
-
-Defining _LINUX_TYPES_H before including <linux/keystone_remoteproc.h> causes
-<linux/types.h> to skip defining kernel types, resulting in undefined __u32
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- src/daemon/mpmdlif.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
-index 0c31604..1abd00f 100644
---- a/src/daemon/mpmdlif.c
-+++ b/src/daemon/mpmdlif.c
-@@ -46,7 +46,6 @@
- #include <byteswap.h>
- #include <stdint.h>
-
--#define _LINUX_TYPES_H
- #include "linux/keystone_remoteproc.h"
- #include "internal/rsc_types.h"
- //#include <elf.h>
---
-2.7.4
-
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index b3479fb9..07512603 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -5,8 +5,6 @@ include multiprocmgr.inc
SRC_URI += " \
file://mpmsrv-daemon.service \
- file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
- file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
"
PR = "${INC_PR}.2"