summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/k3conf/k3conf_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/k3conf/k3conf_git.bb b/recipes-devtools/k3conf/k3conf_git.bb
new file mode 100644
index 00000000..52c2fcf6
--- /dev/null
+++ b/recipes-devtools/k3conf/k3conf_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Diagnostic tool for TI K3 processors"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=37f4e460bd8501c6f02ce71f02bc7ccf"
+
+PV = "0.1+git${SRCPV}"
+
+COMPATIBLE_MACHINE = "k3"
+
+BRANCH ?= "master"
+SRCREV = "9199c3a3b6ec5603a2c4283410b4761e79e81e82"
+
+SRC_URI = "git://git.ti.com/k3conf/k3conf.git;protocol=git;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+ oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${S}/k3conf ${D}${bindir}
+}