aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-docopt_0.6.2.bb10
-rw-r--r--recipes-devtools/python/python-dosocs2-native_0.16.1.bb45
-rw-r--r--recipes-devtools/python/python-dosocs2-natives34
-rw-r--r--recipes-devtools/python/python-dosocs2/0001-setup.py-delete-the-depends-install.patch34
-rw-r--r--recipes-devtools/python/python-jinja2_%.bbappend3
-rw-r--r--recipes-devtools/python/python-magic_5.22.bb21
-rw-r--r--recipes-devtools/python/python-markupsafe-native_0.23.bb14
-rw-r--r--recipes-devtools/python/python-psycopg2-native_2.6.1.bb21
-rw-r--r--recipes-devtools/python/python-sphinx-native_1.3.1.bb17
-rw-r--r--recipes-devtools/python/python-sqlalchemy_0.7.9.bbappend1
10 files changed, 195 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-docopt_0.6.2.bb b/recipes-devtools/python/python-docopt_0.6.2.bb
index e51aeba..7115d0e 100644
--- a/recipes-devtools/python/python-docopt_0.6.2.bb
+++ b/recipes-devtools/python/python-docopt_0.6.2.bb
@@ -2,16 +2,16 @@ DESCRIPTION = "Pythonic command line arguments parser, that will make you smile
HOMEPAGE = "http://docopt.org"
SECTION = "devel/python"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=2c9872d13fa571e7ba6de95055da1fe2"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=09b77fb74986791a3d4a0e746a37d88f"
SRC_NAME = "docopt"
SRC_URI = "https://github.com/docopt/docopt/archive/${PV}.tar.gz;downloadfilename=${SRC_NAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRC_NAME}-${PV}/"
-SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1"
-SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37d4904c"
+SRC_URI[md5sum] = "a6c44155426fd0f7def8b2551d02fef6"
+SRC_URI[sha256sum] = "2113eed1e7fbbcd43fb7ee6a977fb02d0b482753586c9dc1a8e3b7d541426e99"
-inherit distutils
+inherit setuptools python-dir
-BBCLASSEXTEND = "native" \ No newline at end of file
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-dosocs2-native_0.16.1.bb b/recipes-devtools/python/python-dosocs2-native_0.16.1.bb
new file mode 100644
index 0000000..60f3029
--- /dev/null
+++ b/recipes-devtools/python/python-dosocs2-native_0.16.1.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "SPDX 2.0 document creation and storage"
+HOMEPAGE = "https://github.com/DoSOCSv2/DoSOCSv2"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "python-docopt-native"
+DEPENDS += "python-native"
+
+SRC_URI = "https://github.com/DoSOCSv2/DoSOCSv2/archive/v0.16.1.tar.gz \
+ file://0001-setup.py-delete-the-depends-install.patch \
+ "
+
+SRC_URI[md5sum] = "ecb3f47eb9f7cdd01f520e7843ef09b1"
+SRC_URI[sha256sum] = "868e4c1658bd54546f6f65be9770a80ac98793da3dcb71120a52237b07a1a656"
+
+S = "${WORKDIR}/DoSOCSv2-${PV}/"
+
+inherit distutils native
+
+DEPENDS += "python-jinja2-native python-native"
+DEPENDS += "python-psycopg2-native python-docopt-native python-sqlalchemy-native file-native"
+
+python do_dosocs2_init(){
+ import os
+ import subprocess
+ import bb
+ import oe.utils
+ import string
+
+ bb.note("*********PATH = %s!" % os.getenv('PATH'))
+ dosocs2_cmd = bb.utils.which(os.getenv('PATH'), "dosocs2")
+ dosocs2_init_cmd = "%s dbinit --no-confirm" % (dosocs2_cmd)
+ bb.note(dosocs2_init_cmd)
+ try:
+ complementary_pkgs = subprocess.check_output(dosocs2_init_cmd,
+ stderr=subprocess.STDOUT,
+ shell=True)
+ return
+ except subprocess.CalledProcessError as e:
+ bb.fatal("Could not invoke dosocs2 dbinit Command "
+ "'%s' returned %d:\n%s" % (dosocs2_init_cmd, e.returncode, e.output))
+}
+
+addtask do_dosocs2_init after do_populate_sysroot
diff --git a/recipes-devtools/python/python-dosocs2-natives b/recipes-devtools/python/python-dosocs2-natives
new file mode 100644
index 0000000..41f6bb2
--- /dev/null
+++ b/recipes-devtools/python/python-dosocs2-natives
@@ -0,0 +1,34 @@
+From d282ba074625922d12615af676ac1f0e922db88f Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Wed, 15 Feb 2017 23:23:53 +0900
+Subject: [PATCH] setup.py: delete the depends install
+
+Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
+---
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 527b161..b35863f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -3,16 +3,9 @@ from setuptools import setup
+ _dosocs2_version = '0.16.1'
+
+ install_requires=[
+- 'jinja2',
+- 'python-magic',
+- 'docopt',
+- 'SQLAlchemy',
+- 'psycopg2'
+ ]
+
+ tests_require=[
+- 'pytest',
+- 'mock'
+ ]
+
+ setup(
+--
+1.8.4.2
+
diff --git a/recipes-devtools/python/python-dosocs2/0001-setup.py-delete-the-depends-install.patch b/recipes-devtools/python/python-dosocs2/0001-setup.py-delete-the-depends-install.patch
new file mode 100644
index 0000000..41f6bb2
--- /dev/null
+++ b/recipes-devtools/python/python-dosocs2/0001-setup.py-delete-the-depends-install.patch
@@ -0,0 +1,34 @@
+From d282ba074625922d12615af676ac1f0e922db88f Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Wed, 15 Feb 2017 23:23:53 +0900
+Subject: [PATCH] setup.py: delete the depends install
+
+Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
+---
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 527b161..b35863f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -3,16 +3,9 @@ from setuptools import setup
+ _dosocs2_version = '0.16.1'
+
+ install_requires=[
+- 'jinja2',
+- 'python-magic',
+- 'docopt',
+- 'SQLAlchemy',
+- 'psycopg2'
+ ]
+
+ tests_require=[
+- 'pytest',
+- 'mock'
+ ]
+
+ setup(
+--
+1.8.4.2
+
diff --git a/recipes-devtools/python/python-jinja2_%.bbappend b/recipes-devtools/python/python-jinja2_%.bbappend
new file mode 100644
index 0000000..8fd4f24
--- /dev/null
+++ b/recipes-devtools/python/python-jinja2_%.bbappend
@@ -0,0 +1,3 @@
+BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} = "python-sphinx python-markupsafe"
diff --git a/recipes-devtools/python/python-magic_5.22.bb b/recipes-devtools/python/python-magic_5.22.bb
new file mode 100644
index 0000000..5e0a4a2
--- /dev/null
+++ b/recipes-devtools/python/python-magic_5.22.bb
@@ -0,0 +1,21 @@
+SUMMARY = "File classification tool: python-magic"
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+HOMEPAGE = "http://www.darwinsys.com/file/"
+SECTION = "console/utils"
+
+# two clause BSD
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://setup.py;md5=1cf0577ca152455b257b815fcc8517de"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "8fb13e5259fe447e02c4a37bc7225add"
+SRC_URI[sha256sum] = "c4e3a8e44cb888c5e4b476e738503e37fb9de3b25a38c143e214bfc12109fc0b"
+
+S="${WORKDIR}/file-${PV}/python"
+
+inherit setuptools python-dir
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-markupsafe-native_0.23.bb b/recipes-devtools/python/python-markupsafe-native_0.23.bb
new file mode 100644
index 0000000..18860e9
--- /dev/null
+++ b/recipes-devtools/python/python-markupsafe-native_0.23.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
+HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c6d1adcf45d69359f256c1cea3254127"
+
+PR = "r0"
+
+SRC_URI[md5sum] = "f5ab3deee4c37cd6a922fb81e730da6e"
+SRC_URI[sha256sum] = "a4ec1aff59b95a14b45eb2e23761a0179e98319da5a7eb76b56ea8cdc7b871c3"
+
+PYPI_PACKAGE = "MarkupSafe"
+inherit pypi setuptools native
+
+DEPENDS_${PN} += "${PYTHON_PN}-native"
diff --git a/recipes-devtools/python/python-psycopg2-native_2.6.1.bb b/recipes-devtools/python/python-psycopg2-native_2.6.1.bb
new file mode 100644
index 0000000..6f52621
--- /dev/null
+++ b/recipes-devtools/python/python-psycopg2-native_2.6.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python-PostgreSQL Database Adapter"
+HOMEPAGE = "http://initd.org/psycopg/"
+SECTION = "devel/python"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c9872d13fa571e7ba6de95055da1fe2"
+
+PR = "r0"
+SRCNAME = "psycopg2"
+
+inherit native
+
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1"
+SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37d4904c"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
diff --git a/recipes-devtools/python/python-sphinx-native_1.3.1.bb b/recipes-devtools/python/python-sphinx-native_1.3.1.bb
new file mode 100644
index 0000000..113764b
--- /dev/null
+++ b/recipes-devtools/python/python-sphinx-native_1.3.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python documentation generator"
+HOMEPAGE = "http://sphinx-doc.org/"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6dd095eaa1e7a662b279daf80ecad7e6"
+
+PR = "r0"
+SRCNAME = "Sphinx"
+
+SRC_URI = "http://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8786a194acf9673464c5455b11fd4332"
+SRC_URI[sha256sum] = "1a6e5130c2b42d2de301693c299f78cc4bd3501e78b610c08e45efc70e2b5114"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools native
diff --git a/recipes-devtools/python/python-sqlalchemy_0.7.9.bbappend b/recipes-devtools/python/python-sqlalchemy_0.7.9.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/recipes-devtools/python/python-sqlalchemy_0.7.9.bbappend
@@ -0,0 +1 @@
+BBCLASSEXTEND = "native"