aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-lid_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-lid_git.bb')
-rw-r--r--recipes-devtools/python/python-lid_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-lid_git.bb b/recipes-devtools/python/python-lid_git.bb
new file mode 100644
index 0000000..1897f46
--- /dev/null
+++ b/recipes-devtools/python/python-lid_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Identify OS licenses and OS license text in source code."
+HOMEPAGE = "https://source.codeaurora.org/external/qostg/lid/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3dd6f349067c9c1c473ae3f54efeb2e0"
+
+SRC_URI = "git://source.codeaurora.org/external/qostg/lid;protocol=https \
+ "
+
+S = "${WORKDIR}/git"
+
+SRCREV = "d4ec360b51f34e8e73dcad7b0539fc0029eb7a20"
+BRANCH = "master"
+PV = "1"
+
+inherit distutils pythonnative setuptools python-dir
+
+DEPENDS += "python-pyyaml-native \
+ python-future-native \
+ python-nltk-native \
+ python-six-native \
+ python-chardet \
+ "
+
+BBCLASSEXTEND = "native"